Support » Plugin: WP-Stateless - Google Cloud Storage » WP-Stateless 3.2.0 critical error on PHP < 7.2

  • The 3.2.0 updates gives a critical error on servers running PHP versions below 7.2, this is caused by the Monolog 2 package that wp-stateless provides. Cause of the error explained here:

    https://github.com/googleapis/google-api-php-client/issues/1826

    This will affect quite a lot of servers running e.g. Debian stable that cannot easily be updated to PHP version above 7.0, so it would be good if wp-stateless could offer a workaround for this.

Viewing 1 replies (of 1 total)
  • Plugin Contributor Vladimir Palant

    (@planvova)

    Hello @litemotiv,

    Thank you for your notice.

    WordPress team forced us to upgrade third party libraries to the latest version, it includes Google API Client and PHP-JWT libraries which have requires PHP 7.2 or above.

    You can use WP-Stateless version 3.1.1 with PHP 7.0 or below.

Viewing 1 replies (of 1 total)
  • The topic ‘WP-Stateless 3.2.0 critical error on PHP < 7.2’ is closed to new replies.