Support » Installing WordPress » WP SQL Errors on Upgrade 0.7 to 1.0.2

  • Hi!
    I’m trying to upgrade my WP from 0.7 to 1.0.2 and it seems to be impossible for me.
    A basic fresh install for 1.0.2 works fine. Neither the upgrade.php nor the import-b2.php scripts seem to work for me.
    I get a LOT of mySQL Errors like this one from upgrade.php:
    SQL/DB Error —
    [You have an error in your SQL syntax near ‘( option_id int(11) NOT NULL auto_increment, blog_id int(11) NOT NULL defa’ at line 2]
    and the last error is this one:
    Fatal error: Call to undefined function: sanitize_title() in /Volumes/Wigwam/WebServer/quantumpair/Documents/wp-admin/upgrade-functions.php on line 569
    No go from here.
    When trying to import from 0.7
    Step 1 goes well, then Errors rain on me in step 2:

    First we’re going to add excerpt, post, and password functionality…
    SQL/DB Error —
    [Duplicate column name ‘post_excerpt’]
    SQL/DB Error —
    [Duplicate column name ‘post_status’]
    That went well! Now let’s clean up the b2 database structure a bit…

    WP making fun of me, as it did not go well. :-/
    goes on with a bunch of errors like in upgrade.php and closes with:
    Fatal error: Call to undefined function: sanitize_title() in /Volumes/Wigwam/WebServer/quantumpair/Documents/wp-admin/upgrade-functions.php on line 569
    I know these problems look a lot like many people had with upgrading to 1.0.1 but this is definitely when using 1.0.2 which solved problems for so many.
    I also tried to manually move my posts from the old db (of which I surely have a backup πŸ™‚ ) to the new one, but that didn’t work either. (After removing the post_karma the SQL part went fine but WP 1.0.2 still choked on me.)
    I basically would be absolutely fine with a clean install and a way to port my postings and comments from my old WP to the new one. I don’t need anything else (like links, users, etc).
    Systeminfo: Mac OS X Server 10.3.2 running Apache 1.3.29, Perl 5.8, PHP 4.3.2, mySQL 3.23.55 running under Mac OS X Server 10.2.8 (yes that is on a different machine than the webserver)

Viewing 1 replies (of 1 total)
  • The prooblem was that my WP was 0.70 and not 0.71 or 0.72. The upgrade script didn’t get along well with that and upgrading to 0.72 beforehand didn’t work either. Very strange behaviour, and unfortunately no helpful error messages.
    By now I managed to manually migrate all the posts and comments to the new database and we’re currently starting our work on the CSS thus beginning the more creative process.
    Thanks for the generous offer to migrate the db for me.
    Pepi [ running WP 1.0.2 now πŸ™‚ ]

Viewing 1 replies (of 1 total)
  • The topic ‘WP SQL Errors on Upgrade 0.7 to 1.0.2’ is closed to new replies.