WordPress.org

Support

Support » Plugins and Hacks » [Resolved] WP Splash Image triggered a fatal error.

[Resolved] WP Splash Image triggered a fatal error.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’m getting the same message. The details are:

    Parse error: syntax error, unexpected $end in /blah/blah/blah/wordpress/wp-content/plugins/wsi/wp-splash-image.php on line 1006

    Any suggestions? Many thanks.

    Plugin Author ben-barbier

    @agent022

    Yes, try the new version (1.3.3) 😉

    OK. Thanks, but now I’m getting this:

    Parse error: syntax error, unexpected $end in /blah/blah/blah/wordpress/wp-content/plugins/wsi/wsi/WsiFront.class.php on line 280

    BTW, I’m using wordpress version 3.3….?

    Plugin Author ben-barbier

    @agent022

    They are nothing at line 280… this is only the end of my class file.
    What is your PHP version ?
    I use the version 5.3.6 of PHP, could you try with at least this version ?

    The server is running 5.3.1 of PHP, and that’s something I have no control over. My local machine is 5.3.6 and it worked OK.

    Plugin Author ben-barbier

    @agent022

    OK.
    I’ve find one “space” character at the end of WsiFront.class.php (on line 280).
    I’ve remove it on version 1.3.4.

    Could you try the new version ?

    Tkx.

    Sorry man, same issue (same line number)

    Plugin Author ben-barbier

    @agent022

    I Have Find !!!!!

    The problem come from your PHP configuration.
    We must set : short_open_tag = On in your file php.ini.

    I’ll work on a patch now but I don’t know if I’ll succeed ;-).

    ++

    Cool. I’ll have to check with the bloke who runs the server, but I doubt that should be a problem. I’ll get back to you.

    Many thanks.

    Plugin Author ben-barbier

    @agent022

    Hello,

    I’ve find a solution for the version 1.4.0
    I’ve replaced all of my
    <? by <?php
    and
    <?= by <?php echo

    We just need to wait after the next version (2 or 3 hours) 😉

    ++

    Plugin Author ben-barbier

    @agent022

    The new version is arrived !!!
    😉
    Could you test the correction on your server ?

    Tested, and it works. Nice one man.

    Many thanks. Buon anno.

    Plugin Author ben-barbier

    @agent022

    Cool !
    Thank you for helping me improve this plugin.
    ++

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] WP Splash Image triggered a fatal error.’ is closed to new replies.