Support » Plugin: WP Snow Effect » wp-snow-effect-admin.js:4:14: jQuery.fn.load() is deprecated

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor WPManiax

    (@wpmaniax)

    Hi,

    This issue has been fixed in version 1.1.14

    • This reply was modified 1 year, 11 months ago by WPManiax.
    Thread Starter sleeplessindc

    (@sleeplessindc)

    No it hasn’t been fixed. I tried to send a message on your contact form but it says there is a problem sending the message try again later. Here is the error information.
    I updated WP Snow Effect just now to version 1.1.14. Before updating the plugin, I had a red warning box that said “: jQuery.fn.load() is deprecated”. After making the update I still have the same red warning box that says

    “jQuery Migrate Helper — Warnings encountered
    This page generated the following warnings:

    https://wdcb.stcwdc.org/wp-content/plugins/wp-snow-effect/admin/js/wp-snow-effect-admin.js:4:14: jQuery.fn.load() is deprecated
    Please make sure you are using the latest version of all of your plugins, and your theme. If that is the case, then you may want to ask the developers of the code mentioned in your warnings to update it.”

    Plugin Contributor WPManiax

    (@wpmaniax)

    Seems your site still uses the old version of that file.

    Do you use the any kind of cache? If so you need to flush the cache.

    File should look like this:

    (function ($) {
      "use strict";
    
      $(window).on("load", function () {
        if (!snoweffect.show) return;
        jQuery().jSnow({
          followScroll: true,
          flakes: snoweffect.flakes_num,
          fallingSpeedMin: parseInt(snoweffect.falling_speed_min),
          fallingSpeedMax: parseInt(snoweffect.falling_speed_max),
          flakeMaxSize: parseInt(snoweffect.flake_max_size),
          flakeMinSize: parseInt(snoweffect.flake_min_size),
          flakeColor: [snoweffect.flake_color],
          vSize: snoweffect.vertical_size,
          fadeAway: snoweffect.fade_away,
          zIndex: snoweffect.flake_zindex,
          flakeCode: ["&" + snoweffect.flake_type + ";"],
        });
      });
    })(jQuery);

    Actually this is the changed line:

    $(window).on("load", function () {

    Plugin Contributor WPManiax

    (@wpmaniax)

    ohh, sorry, My bad. Thats different file.

    Let me fix that.

    Plugin Contributor WPManiax

    (@wpmaniax)

    Hi,

    Version 1.1.15 has been released. Please update and let me know the results.

    Thread Starter sleeplessindc

    (@sleeplessindc)

    Hi,
    Updating to version 1.1.15 helped. I cleared the cache and refreshed the page and the error message is gone.
    Thank you.

    • This reply was modified 1 year, 11 months ago by sleeplessindc.
    Plugin Contributor WPManiax

    (@wpmaniax)

    Cool. I’m happy it works for you now. Thanks for reporting the issue.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘wp-snow-effect-admin.js:4:14: jQuery.fn.load() is deprecated’ is closed to new replies.