WordPress.org

Forums

[resolved] wp-slimstat-ex on WP 2.5 (14 posts)

  1. joelschou
    Member
    Posted 7 years ago #

    I have a client running WP 2.3.3. He's obsessed with having a hit counter (yes, hits) in the sidebar of his blog. I found the wp-slimstat-ex plugin, which conveniently came with an easy way to to just that. Recently he asked me to upgrade him to WP 2.5 but in my testing, I've found that wp-slimstat-ex throws a fatal error when I try to activate it. My client has thus requested that I skip the 2.5 upgrade if I can't make the hit counter work. Unfortunately, there's no sign of life on the developer's web site, so I'm wondering if anyone worked with this plugin and gotten it functioning on 2.5.

    Now, a different angle: I've emailed back and forth with the guy who made wp-slimstat (notice the difference) work on 2.5 and he sent me some code to add the hits to the sidebar. I have it running just fine on my dev server, but I'm 99% sure that my client won't want to restart his hit count at zero...and I haven't the skills to import the wp-slimstat-ex stats into wp-slimstat, as the DB setups for the two are different. Does anyone know a way to pull this off?

    Thanks for any feedback you can give!

  2. bitsofreality
    Member
    Posted 7 years ago #

    If you've been using wordpress.com stats on that blog you could use that data so you won't start from zero. You can display wordpress.com stats using my stats helper plugin.

  3. joelschou
    Member
    Posted 7 years ago #

    He was actually on wordpress.com before we moved him to a different server. With that move, he wanted to start fresh with everything so that's why I'm using wp-slimstat-ex. Thanks for the suggestion, though. I appreciate it.

  4. Detective
    Member
    Posted 7 years ago #

    I use wp-slimstat-ex with WP2.5 without problems. Which warning are you getting?

  5. joelschou
    Member
    Posted 7 years ago #

    It simply tells me this:

    Plugin could not be activated because it triggered a fatal error.

    That's it. I'd like some more info, but that's all I get. I'm running v 1.606 of wp-slimstat-ex.

  6. gormful
    Member
    Posted 7 years ago #

    Might be a conflict another plugin. Try deactivating all the plugins and activating wp-slimstat-ex and then reactivate one by one all the other plugins to find out which plugin conflicts with wp-slimstat-ex.

    HTH

    Will
    http://will.ph/

  7. joelschou
    Member
    Posted 7 years ago #

    The only other one I had activated was WordPress Database Backup. I turned it off and wp-slimstat-ex still wouldn't start. It threw the same fatal error.

  8. joelschou
    Member
    Posted 7 years ago #

    In case anyone is curious, I was able to pull together all the updated files from the 082net.com repository and build a wp-slimstat-ex v1.61 that works just fine on WP 2.5.1. I guess that means this is nicely resolved.

  9. Ovidiu
    Member
    Posted 7 years ago #

    would you share your version as zipfile maybe?

  10. Ovidiu
    Member
    Posted 7 years ago #

    I can't seem to understand this trac stuff. isn't there a way to download all files at once? do I really have to open each and download?

  11. sept00
    Member
    Posted 7 years ago #

    I just replaced the updated files from the TRAC system and it's working like a charm right now. If you want to download a ready to install ZIP-file, I put one up on my site: http://www.uni-giessen.de/demokratische-linke/termine/wp-slimstat-ex-plugin-v161/

    As far as I can see, I included all changes in the version 1.61. If you find anything awry, please let me know here or on my blog.

  12. Ovidiu
    Member
    Posted 7 years ago #

    thx, I downloaded it and there seems to be no problem at all until now. Just works :-) thx for putting it together.

  13. joelschou
    Member
    Posted 7 years ago #

    Thanks for doing that, sept00. I meant to, got distracted, and then forgot to get around to it. Glad it's working for you Ovidiu!

  14. flick
    Member
    Posted 7 years ago #

    Cheers for this as well, sept00 :) I haven't tested it yet, but one of my concerns about upgrading my 2.3 site to 2.5 was the fact that I wouldn't be able to use SlimStat-Ex anymore!

Topic Closed

This topic has been closed to new replies.

About this Topic