WordPress.org

Forums

WP Slimstat
[resolved] WP SlimStat and target="_blank" link problems (3 posts)

  1. martysparadox
    Member
    Posted 4 years ago #

    I'm running WP 3.0.1 with WP SlimStat 2.0.8.

    After recently and thoroughly updating my WP installation, including the plugins and themes, I realized earlier today that links on my site with target="_blank" would no longer open in a new window or tab. I verified this with Firefox and IE. It seems pretty bizarre (the embedded links are correctly formed and work when that block is pulled into a barebones HTML file).

    After ruling out the theme (used default) and all other plugins (disabled them) I finally disabled the WP-SlimStat plugin, and the problem disappeared. To be specific this problem only occurs when the SlimStat setting "Enable JS Tracking" is turned on. I'm not quite sure what the value of that setting is but it certainly has a very annoying side-effect right now.

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. camu
    Member
    Plugin Author

    Posted 4 years ago #

    Hi there, this issue has been addressed already, and will be fixed in WP SlimStat 2.0.9. As a temporary fix you may want to register to my support forum and download a new version of the Javascript that comes with the plugin, which is the "culprit":

    http://lab.duechiacchiere.it/index.php?topic=30.0

    Otherwise feel free to contact me directly and I'll be more than happy to send you a "preview" version of WP SlimStat 2.0.9 :) The "value" of the Javascript is to track outbound links, aka clicks from your site to another site, and files downloaded from your site. It also tracks browser-related information, like screen resolution, css version of the browser, etc.

    Thank you
    Camu

  3. camu
    Member
    Plugin Author

    Posted 4 years ago #

    Hi there, did you have a chance to download the updated wp-slimstat.js that solves this issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic