Support » Themes and Templates » WP site not displaying properly on some computers

  • I’ve used F2 as the basis for my customised theme and it displays perfectly on my iMac, MacBook Pro and my old Acer laptop. However, on some PCs and Macs, it doesn’t display properly at all. Elements of the original F2 styling creep in and the layout is all over the place. Help please!

    http://www.ourchoicecoventry.org.uk

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator t-p

    (@t-p)

    Volunteer Moderator

    However, on some PCs and Macs, it doesn’t display properly at all.

    all these computers have same browser all different browsers?

    You may want to sort out markup errors.

    Thanks for your response. I’m not sure which browsers are being used, but I think one of the problems is with Internet Explorer, though it looks fine on my laptop using IE. It also looks fine in Firefox and Safari on my Mac and MacBook Pro.

    I’ve had a look at the markup errors, but I don’t really understand them.

    Any other suggestions?

    Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

    The markup/code errors you have are technical errors which won’t effect display. Ignore them for now.

    But you need to find out exactly which browsers and which versions have the display problems. If the problem browsers are IE 6 for Windows and possibly (very old) IE5 for Macs, then you need to work out the CSS to support that browser and use a conditional comment and an IE specific style sheet for that browser. See quirm.net: WordPress and Conditional Comment CSS IE7-8 can display perfectly while IE6 can be a mess.

    Thanks – I’ll check it out tomorrow

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP site not displaying properly on some computers’ is closed to new replies.