Support » Fixing WordPress » WP Site gone after changing the URL in the settings

  • Resolved robwise


    I change the url in the settings page and poof went the site. I tried to fix it by changing the functions.php and the wp_config file. I even went back through the back end and used myphp to fix it there.

    But it is still gone!!!! What can I do to fix it???

Viewing 15 replies - 1 through 15 (of 28 total)
  • Have you checked out the tips/instructions here:

    If you changed the URL in the setting page, you’ll (almost always) need to move the files somewhere else to match the new URL.

    Yes I did. I want to switch back to the /wordpress site, followed the to restore but it is still gone. The url is

    Any thoughts?

    Well, the files seem to at /wordpress/, site throwing off an error now.

    Are you able to access the error logs for the server–it should give us an idea of why the error is occurring and an idea of how to get it back up.

    If you can access the logs, please copy and paste the error message here (or if it is more than a couple of lines, use and post the link to it).

    How do i access the error logs? What kind of information do I need to do that? I have access to the back end of the site, as well as FTP access.


    Contact your hosting company’s support to ask them where to find the error logs. The server logs aren’t part of WordPress, so they could be a variety of places depending on your host’s config.

    I will contact them and let you know soon!

    What does this mean?

    [Sat Jan 26 01:03:25 2013] [notice] Digest: generating secret for digest authentication …
    [Sat Jan 26 01:03:25 2013] [notice] Digest: done
    [Sat Jan 26 01:03:25 2013] [notice] LDAP: Built with OpenLDAP LDAP SDK
    [Sat Jan 26 01:03:25 2013] [notice] LDAP: SSL support unavailable
    PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/’ – cannot open shared object file: No such file or directory in Unknown on line 0
    [Sat Jan 26 01:03:25 2013] [notice] Apache/2.0.52 (Red Hat) configured — resuming normal operations
    [Sat Jan 26 01:03:26 2013] [error] [client] File does not exist: /var/www/html/World_Impact_Bay_Area
    [Sat Jan 26 01:18:47 2013] [notice] caught SIGTERM, shutting down

    This doesn’t appear to me to have the info I was hoping to see– right now, at that page isn’t working, returning an internal server error. This log doesn’t contain information that error.

    I suppose you may need to be more specific and ask them for the web server logs (apache, etc). I’ll ask for some other folks to chime in on this one too.

    Brandon, Thanks so much for all you help. This is awesome to have such a great support network.

    This is the full log, I thought it was repeating the same error maybe not?

    <script src=”″></script>

    did I do that right. Maybe this works?

    You did good :-). Quick glance says we’re not getting the right errors recorded. Let me get a second opinion.

    I’m sorry for asking you to keep going back to your hosting provider. Can you ask them to enable PHP error logging, or at least, explain that we’re trying to determine what error is causing the 500 error at the /wordpress/ site on your page.

    No prob. I will get a hold of them soon.

    Here is the PHP error log

    [28-Jan-2013 15:03:02] PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/’ – cannot open shared object file: No such file or directory in Unknown on line 0

    Hi there.
    I may be wrong, but it seems like you might have messed up the path to your Home and Site URLs in the Admin Panel. To override that modification, what you could do is hardcode your old values into your wp-config.php file as defined in this section of the corresponding Codex article. That should override the values you set in the Admin Panel.
    If your site was working prior to that change, you should be able to restore it. If you have already moved your blog to the new location, then try hardcoding the new values in there.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘WP Site gone after changing the URL in the settings’ is closed to new replies.