Support » Networking WordPress » wp-signup.php redirect on main Multi-site domain page?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Your links didn’t show because this is a link with no content: <a href="http://www.harponthis.com/forum/signup.png"></a>

    I was getting a re-direct to wp-signup.php on the main page of my main domain site: http://www.harponthis.com

    Did http://harponthis.com worked fine? (It’s not now)

    define( 'NOBLOGREDIRECT', 'www.harponthis.com' )

    Mika,

    I have no idea what you’re trying to tell me here. Are you saying to went to my site without the “www” and it worked? Or that it went to the sign-up page? Where am I putting the NOBLOGREDIRECT? WP-config???

    Please advise.

    Thank you,
    Brian

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    I;m asking YOU if your URL, without the WWW, ever worked. It’s not working now, so I want to know if it ever worked. 🙂 I’m new to your site after all.

    NOBLOGREDIRECT goes in wp-config.php, same as all define() calls.

    define( 'NOBLOGREDIRECT', 'http://www.harponthis.com' ); (I forgot the http, sorry) tells your site “Anytime someone comes to a non-existing site, go to this URL instead.”

    However in your case, I don’t know if it’ll work since NEITHER harponthis.com nor http://www.harponthis.com works :/

    Which one is supposed to be the MAIN URL? That is, when you build WP, which one were you using?

    (PS: You don’t need to sign your posts, we can see who you are on the side there.)

    Minka,

    I can see both http://www.harponthis.com and harponthis.com. There is only one page on the main domain site. I have “Welcome to the WordPress incubator” and “Hello and Welcome to the site!” on the first page. In addition, I have a sub-domain working fine off this site. So, yeah, I’m not sure what you you’re seeing or not seeing.

    Adding what you told me:
    define( ‘NOBLOGREDIRECT’, ‘http://www.harponthis.com’ );
    breaks the site on my end. Using both www. and no www. Without it, I see the site just fine using www. and without.

    I just added a “Test Page 1” and it doesn’t go to the page, it just re-cycles back to the main page.

    This is very confusing to me. Thank you for your help.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Mika,

    You see what I see. If you click on the “Test Page1” link, does it take you to that page? It doesn’t work for me, so I doubt it will for you. Any advice or should I just cut my losses, back up wp content and reinstall WordPress?

    Thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Well … see what we’re seeing is wrong, that’s my point. Something is totally messed up.

    I would try a reinstall.

    Ok,

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘wp-signup.php redirect on main Multi-site domain page?’ is closed to new replies.