wp-settings Error? ARGH! (5 posts)

  1. dTrip
    Posted 11 years ago #

    I'm trying to install WordPress, and I've modified my wp-config.php (I'll paste it in below), but when I try to run the install.php, I get this irritating message:
    Fatal error: Failed opening required '//wp-settings.php' (include_path='.:') in //wp-config.php on line 59
    I have no idea what it's talking about or how to fix it. Any help will be greatly appreciated.
    The only thing I can think of is that my MySQL server is my URL prefaced with "mysql." (i.e., http://mysql.richardparent.net) Is this relevant? Here's my wp-config.php:
    /** WordPress's config file **/
    /**http://wordpress.org/ **/
    // ** MySQL settings ** //
    define('DB_NAME', 'richard8'); // The name of the database
    define('DB_USER', 'richard8'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    // Change the prefix if you want to have multiple blogs in a single
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define('ABSPATH', dirname(__FILE__).'/');
    // Get everything else

  2. Mark (podz)
    Support Maven
    Posted 11 years ago #

    The double slashes you are seeing in '//wp-settings.php' is due to your hosts installation of PHP.
    Their setup is adding a slash where one should not be.

  3. dTrip
    Posted 11 years ago #

    Hmm... So, how can I tell WordPress to add another slash?

  4. Mark (podz)
    Support Maven
    Posted 11 years ago #

    You can't .... double slashes break things.
    Your host needs to fix their paths for their php installations. For them to do this is very easy - it's not tricky or expensive, but this isn't a wordpress problem - I would imagine that other software which uses the same parameters inside php will experience the same errors.
    I would email your host and tell them about the double slash problem, but it isn't a wp problem, no matter what they might say.

  5. dTrip
    Posted 11 years ago #

    Will do. Thanks!!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.