Support » Plugin: Participants Database » Wp Session Manager update

  • Resolved Damian

    (@timersys)


    Hi I’m developer from https://geotargetingwp.com We use a newer version of WP session Manager and one customer that it’s using your plugin it’s having issues.

    Would be a chance for you to update the library and using composer or some autoloader to load the class if doesn’t exists?

    We use composer to load the files.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author xnau webdesign

    (@xnau)

    Thanks for the reminder, I’ve been meaning to update that library for a while now.

    If the client’s site is already loading WP Session Manager, then you can prevent Participants Database from loading it on line 309 of participants-database.php That code is checking for the WP Session Manager plugin, but it doesn’t check if the library is getting loaded some other way. You can just comment out the include line.

    If that causes more problems, you may have to wait until I can release the plugin with the latest version of the library. That will happen in the next major release.

    Plugin Author xnau webdesign

    (@xnau)

    One more thing that will complicate things on my end: I’m using version 3.0.4 because it’s compatible with php 5.6 and WP plugins need to have compatibility back to php 5.6

    Thread Starter Damian

    (@timersys)

    Thanks for the prompt reply. Yes we also have a version that doesn’t require php 7, but loaded with composer.
    I will tell the custom to directly comment out the library.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Wp Session Manager update’ is closed to new replies.