Support » Plugin: All In One WP Security & Firewall » WP Security Plugin Block WooCommerce “REST API”

  • I’m attempting to utilize the “Enable the REST API” option in WooCommerce. However, every time I “Activate” the WP Security plugin the connection gets broken. When I “Deactivate” the WP Security plugin all is well.

    Kindly let me know how to resolve this issue.

    I’m using WP v4.8 and WP Security v4.2.8.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I just carried out a test using the latest WordPress version and All In One …… and I could replicate your issue. Can you disable all of your other plugins except WooCommerce and All In One…. Can you carry out another test? Report back.

    Thank you

    Plugin Author wpsolutions

    (@wpsolutions)

    In addition to the suggestions above, please also try disabling any aiowps firewall rules and do some tests to determine if one of those is causing the issue.

    I’m having similar issue when we call a URL for our Oauth plugin.

    /wp-login.php?action=oauth1_authorize&oauth_token={sanitized}&oauth_token_secret={sanitized}&oauth_callback_confirmed=true

    It simply redirects the page to WordPress Admin Dashboard instead of the URL above.

    As soon as I turn off the aiowps plugin it works.

    I have disabled all the functions in the aiowps plugin and still have the problem, it’s only when I turn off the plugin that it all works again.

    I’ve noticed this since updating the aiowps plugin, never had a problem in past versions of the plugin.

    I’m running wordpress 4.8 and aiowps version 4.2.8

    • This reply was modified 3 years, 7 months ago by Wasca.

    I found a temporary solution to my problem.

    line 49 of this file /wp-content/plugins/all-in-one-wp-security-and-firewall/classes/wp-security-wp-loaded-tasks.php

    When I comment out

    //wp_redirect(admin_url());

    I’m no longer redirected to the wp-admin page and I’m sent to the correct oauth page for the Oauth plugin.

    I’ve tested this for when I’m already logged in and when I’m not logged into the site where I’m doing the OAuth.

    Could some one help me remove the action “aiowps_login_init”

    I’m using a child_theme and I’m not sure what I need to do in my functions.php file.

    I’ve tried a few things but it’s not working.

    
    add_action ( 'wp_loaded', 'aiowps_login_init_remove' );
    
    function aiowps_login_init_remove() {
    
    	remove_action('login_init', array( 'AIOWPSecurity_WP_Loaded_Tasks' , 'aiowps_login_init' ) );
    	
    }

    Looks like another smart cookie has already found a solution that also fixed my issue.

    https://wordpress.org/support/topic/already-logged-in-no-captcha/

    Thanks @zitrusblau

    @mbrsolution and @wpsolutions – I disabled all plugins except WP Security and the problem was still there. Also, I disabled all aiowps firewall rules and I still had the problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WP Security Plugin Block WooCommerce “REST API”’ is closed to new replies.