wp-rss2.php fails - WP 1.5 (12 posts)

  1. bobeaston
    Posted 10 years ago #

    Migration to 1.5 via the fine instructions at tamba2 was very smooth. I'm using the "default" Heilemann/Kubrick theme completely unmodified, and 1.5 completely unmodified.

    When accessing an unmodified wp-rss2.php link:

    Firefox 1.0 says "An external application must be launched. ..."

    So, we try FeedDemon, which responds with "Failed to connect..."

    Please give me some hints on how to diagnose this problem. FWIW, the site is only a very rough beginning: http://eleaston.com/bob/wp/


  2. bobeaston
    Posted 10 years ago #

    Additionally, when using Firefox's Live Bookmark facility, the result is a bookmark that says "Live Bookmark feed failed to load."

  3. Anonymous
    Posted 10 years ago #

    Calling index.php instead of the rss.php files per this document worked for me.


    But I'm not sure why the original rss.php files aren't working.

  4. bobeaston
    Posted 10 years ago #

    THANKS Gary! Yes, I too am using an IIS based hosting service. Commenting the lines in wp-blog-headers.php did it for me.

  5. dubbldawg
    Posted 10 years ago #

    Yeah sorry. I can't figure out what part they need changed. I have the same problems.

    Why doesn't this just work from a straightup install?

    It should ship from WordPress working without all these neccessary steps shouldn't it? Can they fix that for the next upgrade?

  6. bobeaston
    Posted 10 years ago #

    My guess is that it works perfectly in a Linux/UNIX hosting environment, and that it's only MS IIS that fails.

  7. Yep. That's what the bug report says.

  8. Ryan Boren
    WordPress Dev
    Posted 10 years ago #

    Indeed, this is IIS only and is fixed with this change:


    All of the other workarounds are unnecessary.

  9. dubbldawg
    Posted 10 years ago #

    Nope. I have Linux hosting and it doesn't work for me either.

  10. Ryan Boren
    WordPress Dev
    Posted 10 years ago #

    It may help in some Apache CGI environments too. Have you tried the fix?

  11. ppp
    Posted 9 years ago #

  12. The above problem should have been fixed in WP v1.5.1 and should no longer be an issue in WP v1.5.1.2.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.