Support » Plugin: WP RSS Aggregator » WP RSS Aggregator plugins breaks after switch to HTTPS

  • Resolved kflavin21

    (@kflavin21)


    We’ve used the WP RSS Aggregator plugin without any issues. Recently, we switched our site from HTTP to HTTPS. As of the switch, the RSS Aggregator has stopped working. Does anyone have any idea why this would happen? It doesn’t seem like a change that would affect the feeds from being imported, the plugin just used Curl.

    When I try to manually import the feeds, it spins for a minute like it’s doing something, but the feeds aren’t imported. The WP RSS error log is also blank.

    Plugin version: 4.11.1

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi @kflavin21,

    Have you tried following the steps outlined on our Feed Items not importing page? If not, please have a go through them and let us know the results.

    Hi Eric,
    Yes, I went through the list. No htaccess, curl is enabled, php version above 5.3.9.

    It had been working for months prior to us switching over the SSL a couple weeks ago. We’re behind an nginx proxy, with SSL terminated at the proxy. I’m wondering if that has something to do with it… wordpress would have been switched over to https, but the backend servers still communicate over standard port 80.

    Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi @kflavin21,

    Have you checked your cron status as well?

    To check the cron status, you will need to install the WP Crontrol plugin and then visit the Tools > Cron Events page.

    If you see any bad cron on this page, as shown here, then the problem you appear to be encountering is what appears to be stuck cron.

    But if your cron is fine, then we suggest you contacting your hosting provider to ask more information about this. You can ask any logs or whatsoever that can help debugging this issue. Since this problem is more likely a server-side issue rather than from the plugin itself.

    kflavin21

    (@kflavin21)

    Hi @erricgunawan,
    I checked the Wp-cron status. I have an error saying curl cannot connect to port 443 of my host. There are a number of “wprss_tech_single_feed_hook” items in the “(now)” state.

    That appears to be part of the problem, so I’ve reached out to my host. In the meantime, I’m trying to manually run wp-cron.php, and the feeds don’t import like that either. I’ve tried to invoke wp-cron.php as follows:

    #1
    $ php wp-cron.php # Appears to run successfully, but feed items still don’t import.

    #2
    $ curl https://mysite/wp-cron.php # fails to run since my backend server can’t talk to 443 on the public domain

    #3
    Enter https://mysite/wp-cron.php into my browser, loads a blank page, and returns a 200 status. Feed items still don’t import.

    If Wp-cron runs, it should import the feeds, correct? Do I need to delete the “stuck” items first?

    • This reply was modified 4 months ago by  kflavin21.
    kflavin21

    (@kflavin21)

    Btw, it’s the “wprss_fetch_single_feed_hook” that appears to be “stuck”. There are several of these, I’m assuming one per each feed. Each time I fetch all feeds from the “debugging” tab in the admin, it adds another set of these events to the cron list. They never complete, even after running wp-cron.php as described above.

    I’ve noticed if I set the wprss log level to “Error or below” in the general settings, I get some output here:

    ./wp-content/log/wprss/log_blg-1.txt

    However, the output only seems to come from the wprss_fetch_insert_all_feed_items() function. I don’t see anything from the wprss_fetch_insert_single_feed_items() function, even though there are numerous log statements within. As near as I can tell, it isn’t actually being executed.

    This was a firewall issue connecting back to the proxy… backend servers could talk to the proxy on 80, but not 443. To resolve this, I scheduled the cron through the OS, rather than rely on WP cron. Additionally, I had to clear out a number of stale wprss_* events. I did this using the wp cli, ie: “wp cron event delete wp_rss_fetch_single_feed_hook”.

    Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi @kflavin21,

    We apologize for the delay in replying due to a high load in our premium support channel lately.

    Thanks for getting back to us.

    From your last reply, does this mean you already have your issue resolved? Or do you still need any of our assistance here?

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.