Support » Plugin: Page Builder by SiteOrigin » WP Rocket Delay JavaScript Execution Issue

  • Resolved twowithink

    (@twowithink)


    Home page hero background image has a major shift/blink until first interaction when WP Rocket Delay JavaScript Execution is enabled: https://beta.speechworks.net/

    I have tried exhaustively to figure out what JS files to exclude in order to remedy the behavior to no avail and take advantage of at least some of the Delay JavaScript Execution benefits in Google Speed Tests.

    We are using ThemeTrust Create Theme and SiteOrigin Page Builder.

    Thank you in advance for your assistance.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 16 through 21 (of 21 total)
  • Thread Starter twowithink

    (@twowithink)

    Hi Alex,

    Thank you for the revised attempt, but still no change. See screenshot: https://beta.speechworks.net/wp-content/uploads/2023/01/screenshot.jpg

    I appreciate your efforts in helping resolve this issue. Thanks.

    Thread Starter twowithink

    (@twowithink)

    Hi Alex,

    UPDATE: I took a closer look after adding your codes and saw that if we also include the .entry-content to the new CSS, it works!!!

    .siteorigin-panels.siteorigin-panels-css-container .body-wrap, .siteorigin-panels.siteorigin-panels-css-container .body-wrap .entry-content {
    max-width: none !important;
    }

    Thank your team for the exceptional help and I’ll consider this ticket closed.

    Best!

    Thread Starter twowithink

    (@twowithink)

    One last thing… While the code you provided works, it turns the Create Theme’s “Default” Template option into full-width stretched rows even if SiteOrigin is set to “Standard”. I edited the CSS to add “.page-template” to address this, unless you have a more eloquent way of making it happen:

    .page-template.siteorigin-panels.siteorigin-panels-css-container .body-wrap, .page-template.siteorigin-panels.siteorigin-panels-css-container .body-wrap .entry-content {
    max-width: none !important;
    }

    Thank you.

    Plugin Contributor alexgso

    (@alexgso)

    Hi,

    It’s great to hear you were able to get it working. 🙂
    Due to how Create handles the theme container a rather complicated override is required for it to work as desired so the CSS in your last reply is effectively the best way of doing this.

    Kind regards,
    Alex

    Thread Starter twowithink

    (@twowithink)

    Great. Thank you again for the FANTASTIC support!

    Plugin Support Andrew Misplon

    (@misplon)

    Thanks for your kind feedback and support; it’s most appreciated. I’m glad we were able to assist. Please, let us know if any queries or requests moving forward.

    Cheers for now 🙂

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘WP Rocket Delay JavaScript Execution Issue’ is closed to new replies.