Support » Plugin: WordPress REST API (Version 2) » WP REST API Plugin support for PHP 7

  • Resolved toddlevy

    (@toddlevy)


    Hello –

    Hoping to use this plugin on a PHP 7 site.

    However, the WPEngine PHP Compatibility Checker plugin and it’s showing the errors below.

    Questions are basically if / when this code may be updated for PHP 7 compatibility?

    Else, is this perhaps a “false positive” that won’t create issues?

    Thank you for any information,
    TL

    —————————–

    FILE: /wp-content/plugins/rest-api/extras.php

    150 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.

    FILE: /wp-content/plugins/rest-api/lib/endpoints/class-wp-rest-comments-controller.php

    588 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    589 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.

    FILE: /wp-content/plugins/rest-api/lib/endpoints/class-wp-rest-posts-controller.php

    773 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    782 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.

    FILE: /wp-content/plugins/rest-api/lib/endpoints/class-wp-rest-revisions-controller.php

    285 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    288 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.

    • This topic was modified 2 years, 6 months ago by toddlevy.
Viewing 1 replies (of 1 total)
  • Plugin Author Ryan McCue

    (@rmccue)

    The WordPress REST API is integrated into WordPress since 4.7, so you no longer need this plugin. Additionally, these are all false positives.

Viewing 1 replies (of 1 total)
  • The topic ‘WP REST API Plugin support for PHP 7’ is closed to new replies.