Support » Plugin: WP-reCAPTCHA » wp-recaptcha plugin needs upgraded when you migrate to WP3

  • reykjavikingur

    (@reykjavikingur)


    I recently started migrating from WP 2.9.2 to WP 3.0.1, and when I ported all my plugins, I suddenly got this error:

    Fatal error: Call to undefined function wp_get_current_user() in /var/www/sites/v1p5.dev.innoblogs.com/public_html/wp-includes/user.php on line 223

    I added a back trace and found it to be a call to is_site_admin(), which is deprecated in WP 3.0.1 in favor of is_super_admin().

    Pretty clear-cut. I’ll try to upgrade the wp-recaptcha plugin and see if it gets better.

  • The topic ‘wp-recaptcha plugin needs upgraded when you migrate to WP3’ is closed to new replies.