WordPress.org

Support

Support » Plugins and Hacks » wp-print problem

wp-print problem

  • I installed gamerz wp-print i got it working with posts but it does not work with pages of my website.

    is it possible to make it work for all the pages of the website or does it apply only to posts

    thanx

    julius

Viewing 15 replies - 1 through 15 (of 41 total)
  • Works fine here on Pages. How are you linking to them?

    I am not linkin it actually and i think it might mìbe the problem.

    Actually i contacted gamerz and he said it is not developed for pages but only for posts.

    So if you can tell me how to do it would be beautiful.

    Thanks

    Julius

    “I am not linkin it actually”

    Then how do you get posts to show in it? Something like:

    wp-print.php?page_id=1

    Works with Pages.

    actually i followed the procedure on the readme file, as i am not using permalink i put

    // Open wp-content/themes/<YOUR THEME NAME>/index.php
    // Note: If you ARE NOT using nice permalink url
    Find:
    ——————————————————————
    <?php while (have_posts()) : the_post(); ?>
    ——————————————————————
    Add Below It:
    ——————————————————————
    “>Print This Article

    That is what i did. The print this article link is showed on either pages or posts but only when i click it on posts i got redirected on the post to print, while when i try to prin a page I got an error message saying ” no post matches your criteria”.

    Gamerz told me it does not work with pages, now if you have another way to make it work, please explain me!

    thanx

    “Gamerz told me it does not work with pages”

    Give this to Gamerz as an answer: replace the “Print” line with

    <?php if(is_page()) : ?>
    <a href="wp-print.php?page_id=<?=the_ID()?>">Print</a>
    <?php else : ?>
    <a href="wp-print.php?p=<?=the_ID()?>">Print</a>
    <?php endif; ?>

    Or if a theme has single.php and page.php templates, use the different print link versions for each (i.e. ?page_id= for page.php, ?p= for single.php).

    Love supporting other peoples’ work…

    cheers mate, nice and easy….i’ll tell gamerz!

    thanx

    Lester Chan
    Participant

    @gamerz

    thanks for the fix bud!

    What is the URL fro gamerz WP Print?

    James Huff
    Support Team Rep.

    @macmanx

    I was getting tired of people arriving at my site via Google and getting the wp-print version rather than the post itself, so I added the following to wp-print.php:
    <meta name=”robots” content=”index,follow” />

    If anyone just happens to be using this and 1.6-do-not-use, have you figured out how to get it to work with the “nice” permalinks? 😉

    you can just put no if you do not want bots

    Oops, thanks GamerZ, I meant “noindex,follow”.

    LOl, no prob

    To Gamerz,

    I had added this plugin to my blog, followed the directions but for some reason kept getting a 500 internal server error page. =( I’m using (nice) permalinks on the blog. Added this like you said in the readme.txt:

    / Go to Manage > Files > Common -> .htaccess (for rewrite rules)
    // Note: If you ARE using nice permalink url
    Find:
    ——————————————————————
    # END WordPress
    ——————————————————————
    Add Below It:
    ——————————————————————
    RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/print/?$ <BLOG URL>/wp-print.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA,L]
    ——————————————————————

    Shouldn’t that be up above the </IfModule> # END WordPress line? I was just curious… I did that via the control panel, then when that failed..I tried it manually and uploaded the same .htaccess file with the changes and still the 500 internal errors. =( I had done all the other stuff as posted in the ReadMe.txt file as well. I then just took out the plugin all together.

    Also, even while at your site looking through the comments for the plugin, someone that had the 500 error as well said something about a fix, but didn’t really explain how to do it. Any suggestions maybe?….thanks. =)

    spencerp

    The </IfModule> will check to make sure that you have mod_rewrite activated, you have it activated/installed, it should not pose a problem.

    Did you replace <BLOG URL> with your url to the wordpress folder. If your wordpress folder is in the root, it will be like this.
    ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/print/?$ /wp-print.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA,L]

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘wp-print problem’ is closed to new replies.