WordPress.org

Forums

WP-Print Plugin (5 posts)

  1. katie1
    Member
    Posted 9 years ago #

    Hi guys,

    For some reason undefined, my wp-print doesn't seem to want to play anymore. When I click on "Print This Article" under the nominated post, I get a standard "internet" 404 error. I'm using Permalinks, /%category%/%post_name%/%post_id%/.

    My WP version is the latest upgrade, and my host uses apache 1.3. I'm not using lucky13 re-write plugin because every time I try to install it my site goes ballistic!

    Footnote: Up until today - right now in fact - I had no problem with any aspect of this install or Permalinks (minus lucky13) although I did require additional help from the Lester to get the print plugin to work when I first installed it, but he waved his magic wand and fixed my problem. Only today, for some reason, it doesn't bring up a print version of the article.

    I've uninstalled all plugins I've added since his help, and the print function still doesn't want to play. The url for the article is: myblog/wordpress/submissions/the-dream/26/

    The print URL for the article is: myblogname/wordpress/submissions/the-dream/26/print

    The standard error page URL: myblogname/wordpress/submissions/the-dream/26/print/

    Within the actual post...

    <div id="maincontainer"><br>
    <?php if (have_posts()) : ?><br>
    <?php while (have_posts()) : the_post(); ?><br>
    <div class="entry single">
    <h2><a href="<?php the_permalink() ?>"><?php the_title(); ?></a></h2><br>
    <p class="byline"><span>by </span><?php the_author(); ?><br>
    <p class="issue"><?php the_time('F jS, Y') ?><br>
    <p class="info"><?php if ($post->comment_status == "open") ?><br>
    <?php the_content();?><br>
    <p id="filedunder">Filed under: <?php the_category(','); ?> | href="<?php the_permalink(); ?>print/">Print This Article
    </div>

    I also noticed a URL discrepency whenever I hover over the article title within Manage/Posts. The URL there is: myblogname/wordpress/category/submission.

    When I click my way down (sub-cat levels) I have category in the url until the actual post is rendered. I've read that /category/ within the URL structure is innate and cannot be overridden whilst using Permalinks. I don't have an issue with this but I couldn't help but wonder if this (/category/) is affecting the ability to render a print version.

    I could be wrong - most probably am. Can someone please advise how I could go about fixing this issue, again?

    Thanks very muchly

  2. katie1
    Member
    Posted 9 years ago #

    Can someone please help me on this issue? Unfortunately, I don't know enough php to correct this by myself, nor am I overly confident with touching my htaccess given that Lester kindly had to correct some issues in order to get the plugin to work in the first instance.

    thank you

  3. yurivs
    Member
    Posted 9 years ago #

    Hi
    Print plugin doesn't work anymore under WordPress 2.0...
    :(
    Yuri
    ___
    http://blog.karaloka.net

  4. Null
    Member
    Posted 9 years ago #

    What wrong with the print button in your browser?

  5. spencerp
    Member
    Posted 9 years ago #

    Hey Kate, don't feel bad, my print plugin didn't work either with version 2.0. I then had downloaded and installed GamerZ new version of the plugin that works with WordPress 2.0.
    http://wordpress.org/support/topic/53810?replies=14

    And then had him go into the Blog's CP and fix accordingly. =) Because I had been using a certain permalink structure for the blog.

    Also, just for other's to know, GamerZ has updated all his plugins now, to be compatible with WordPress 2.0. =)

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic