Support » Plugins and Hacks » Wp-Polls 1.5 updated

  • I downloaded the new updated 1.5 wp-polls from gamerz.

    I have installed it and it displays correctly but it is not recording votes.

    When I attempted to run the install script I got these errors (or at least, the second time I tried to run it. ran into some problems on first attempt)

    WordPress database error: [Table ‘wp_pollsa’ already exists]
    CREATE TABLE wp_pollsa ( aid int(10) unsigned NOT NULL auto_increment, qid int(10) NOT NULL default ‘0’, answers varchar(200) NOT NULL default ”, votes int(10) NOT NULL default ‘0’, PRIMARY KEY (aid))

    WordPress database error: [Table ‘wp_pollsq’ already exists]
    CREATE TABLE wp_pollsq ( id int(10) unsigned NOT NULL auto_increment, question varchar(200) NOT NULL default ”, timestamp varchar(20) NOT NULL default ”, total_votes int(10) NOT NULL default ‘0’, PRIMARY KEY (id))

    any ideas what i’m doing wrong or why it wouldnt be recording? if its sql i’m probably screwed i know jack about mysql 🙁

Viewing 15 replies - 1 through 15 (of 47 total)
  • I believe I just solved this problem myself. I noticed that when it was looking for the ‘polls archive’ it was pointing to the root domain/wp-polls.php

    I believe that I had uploaded wp-polls.php to the plugin file as the text document instructed (i think anyways)

    So, anyways, its fixed now. If you have trouble installing it, loading wp-polls to the root directory of the blog script was what fixed it for me.

    hrm, maybe not. Its not recording it from the template page (the main page) but will record votes from the wp-polls.php page

    weird as hell 🙁

    one last comment before I try to take a little sleep in, when adding the line

    vote_poll();

    to header.php as the readme instructs, it simply appears at the top of the template as text. am I doing something wrong?

    hi there, sorry for not clarifying in the readme. It should be <?php vote_poll(); ?>

    Cheers

    Based on that first post in this thread, you already have an older version installed…

    Note: f you are already running wp-polls, please run wp-admin/polls-upgrade.php first.

    To get my polls to submit properly (I’m using them on individual entry archives – aka – the single.php template), I had to remove “index.php” from the action… (line 58 of polls.php) Is this normal? Or am I supposed to set wordpress to use explicit file names?

    I tried running the upgrade file and got this error:
    Parse error: parse error, unexpected ‘<‘ in /home/boogie/boogie-blog.com/wp-admin/polls-upgrade.php on line 2

    Oh found the problem there was an extra <PHP line on it. removed it and I think it upgraded fine. (I got the blank page as you suggested I should)

    oh and then I sent a few friends over to vote and I believe it is now recording properly. 🙂

    poll doesnt work properly for me… I can vote, and it records it fine, but when i come back to my page it gives me the questions again when it should just dispplay the results…

    GamerZ – This is a great mod. Is there a way to set it up so Guests or Anons can vote?

    soupenvy: yap that is normal, I created it based on index.php.
    uberwolf: point noted, will fix that.

    nobody-: u tried closing and opening the browser again? I think the cookie is not recordered in your PC

    Working fine for me now.

    Is the file wp-polls supposed to be placed in the home directory of the blog? and not in the plugins folder as stated in the readme file.

    Because thats where it tries to look for it when you click “Polls Archive” under the poll.

    i get the same error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘( aid int(10) unsigned NOT NULL auto_increment, qid int(10) NOT]
    CREATE TABLE ( aid int(10) unsigned NOT NULL auto_increment, qid int(10) NOT NULL default ‘0’, answers varchar(200) NOT NULL default ”, votes int(10) NOT NULL default ‘0’, PRIMARY KEY (aid))

    I tried moving it into the root directory as described above but am still getting the same error, why is this plugin so hard to impliment? am I missing something?

    My votes are only registering when i vote in poll archives. They are not working when done from the sidebar? any ideas?

    problem has been fixed by correctly placing <?php vote_poll(); ?>

    But now when vote is counted and result is shown the top of the page says “Warning: Cannot modify header information – headers already sent by (output started at /home/usman/www/www/index.php:3) in /home/usman/www/www/wp-content/plugins/polls.php on line 80”

    Nevermind guys fixed it it was my mistake

Viewing 15 replies - 1 through 15 (of 47 total)
  • The topic ‘Wp-Polls 1.5 updated’ is closed to new replies.