WordPress.org

Support

Support » Plugins and Hacks » WP Policies Broken in WP3.x

WP Policies Broken in WP3.x

  • I really like this plugin and I am frustrated to distraction that I cannot get it to run on WP3. It doesn’t create its own pages, ‘manage’ doesn’t function and when you create pages for it and insert the relevant codes and invoke from footer.php, nothing shows up. I had this running on 2.9.2 so its really annoying that since I upgraded my WordPress I downgraded my public liability!!!

    Are you going to update it to be compatible with WP3?

    http://wordpress.org/extend/plugins/wp-policies/

Viewing 1 replies (of 1 total)
  • BigShell

    @bigshell

    It is (mostly) working on my WP 3.0.1 install.

    As stated, the “Pages Manager” link and the “Manage” links don’t work as they should because WP renamed the pages that these pointed to. You can still use the plugin without those links or you can edit the plugin code to point to the correct pages in WP3.

    Everything else is working well for me.

    If you are interested in editing the plugin:
    Change:
    <a href="edit-pages.php">Pages Manager</a>
    to
    <a href="edit.php?post_type=page">Pages Manager</a>
    and change:
    <a href="page.php?action=edit&post=<?=$v[0]?>">Manage</a>
    to
    <a href="post.php?action=edit&post=<?=$v[0]?>">Manage</a>

    At least that worked for me. YMMV

Viewing 1 replies (of 1 total)
  • The topic ‘WP Policies Broken in WP3.x’ is closed to new replies.