Support » Plugin: Simple Ajax Chat » WP Plugin SAC: Name and comment require. Please complete all required fields …

Viewing 15 replies - 1 through 15 (of 27 total)
  • Thread Starter ithomson87

    (@ithomson87)

    I thought I’d included something else, but I like the plugin’s simplicity yet it’s clear you have a keen attention for detail / customization. Nice.

    Plugin Author Jeff Starr

    (@specialk)

    Glad to help. Basically in order to investigate and try to help, the issue needs to be repeatable on default WordPress. So that would be the first thing to do, some basic troubleshooting to identify what exactly is happening. The key is to test on *default WordPress install*, with no other plugins active, and using the default theme.

    Thread Starter ithomson87

    (@ithomson87)

    Working on that. In the meantime, could it be the CSS?

    /*chat window*/
    div#simple-ajax-chat{
    width:100%;
    overflow-wrap: break-word;
    margin:0 0 20px 0;}
    div#sac-content{
    display:none;}
    div#sac-output{
    width:100%;
    height:350px;
    overflow:auto;
    border:2px solid #c71f1f;
    border-radius:3px}
    div#sac-output.sac-reg-req{
    float:none;
    width:100%;
    height:auto;
    border:0;}
    div#sac-latest-message{
    padding: 5px 10px;
    color: #ffffff;
    font-weight: 700;
    font-size: 14px;
    background-color: #0c1e82;
    text-align: center;
    position: sticky;
    z-index: 9999;
    top: 0;
    width: 100%;
    border-top-left-radius: 1px;}
    span.sac-chat-name {
    color:#c71f1f;
    font-weight:600}
    ul#sac-messages{
    margin:10px 0;
    padding:0;
    font-size:14px;
    line-height:20px;}
    ul#sac-messages li{
    margin:0;
    padding:4px 10px;}
    /*chat author*/ #sac-user-chat label {
    display:none}
    #sac-user-info {
    padding:10px 0 5px}
    div#sac-panel{}
    form#sac-form fieldset{
    margin:5px 0 5px 0;
    padding:0;
    border:0;}
    form#sac-form fieldset label,
    form#sac-form fieldset input,
    form#sac-form fieldset textarea{
    clear:both;
    width:100%;
    margin:0 0 2px 0;
    font-size:14px;
    height:30px;}
    .tooltip{
    border:0;
    text-shadow:none;}
    /*chat submit button*/ #submitchat {
    margin-top:5px;
    background:#0c1e82 !important;
    border-radius:3px !important;
    border:2px solid #0c1e82 !important;
    color:#ffffff !important;
    font-weight:700 !important;
    padding: 3px 10px 3px 10px;
    font-size:14px !important}
    #submitchat:hover,
    #submitchat:active {
    border:2px solid #c71f1f !important;
    background: #c71f1f !important;}`

    Thread Starter ithomson87

    (@ithomson87)

    Turned plugins off. Still having an issue.

    Looks like I’d removed the CSS also. I didn’t reset to default, but I had previously tried that. Can do again.

    Plugin Author Jeff Starr

    (@specialk)

    It’s great investigating, ultimately however only one thing is needed: the steps to repeat the error on *default WP site*. My advice would be to start with a new WP install, activate only SAC, and leave all settings at default values. Then in that environment, try again with the mobile phone or whatever scenario.

    • This reply was modified 9 months, 1 week ago by Jeff Starr.

    Just set up this plugin and exact same thing, same message, is happening here, only on every test message, and on a laptop… Haven’t checked mobile yet…

    I am using the 2021 theme and not a whole lot going on, though some things…

    Inspecting the message generated on its new blank error page, its div class is wp-die-message…

    When I click the browser back button and then reload the page, the test messages do then show up…

    I’m willing to give you Admin access to the site, in case you might be interested in checking things out, maybe see what is going on…? It is a non-profit site and my efforts are contributed…

    Kind regards… ๐Ÿ™๐Ÿฝ

    Plugin Author Jeff Starr

    (@specialk)

    @crzyhrse it’s pretty much the same thing: in order to help, we need the steps to repeat the error on *default WP site*. Difficult to do anything without that infos. Also we’re not allowed to log in to any user sites just fyi.

    Thanks Jeff for getting back so quickly… I’ll keep chasing it down, will report back if I find anything… ๐Ÿ™๐Ÿฝ

    Plugin Author Jeff Starr

    (@specialk)

    Hi @ithomson87, just wanted to follow up with this. Itโ€™s been awhile with no reply, so I hope the issue is resolved? Or if there is anything I can do to help, please let me know. Thank you.

    Plugin Author Jeff Starr

    (@specialk)

    Hey @ithomson87, I hope you got this sorted. Itโ€™s been awhile with no reply so gonna go ahead and mark this thread as resolved to help keep the forum organized. Feel free to post again with any further questions or feedback, Thank you.

    Same error here. It seems nobody wana test ur advise with the clean WP install.

    I install now a clean wp and test it. I write u when iam done.

    Regards

    Plugin Author Jeff Starr

    (@specialk)

    Thanks @constantincg, let us know what you find.

    WordPress is allready installing.

    What i noticed is, if i put the shortcode in a site or article it works. In my case the chat is only not working when i put the chatbox in a widget on the mainpage for example.

    U can test the message here:

    https://crypto-grid.net/

    Plugin Author Jeff Starr

    (@specialk)

    The form is read-only, there is no way to test it. You can change that in the plugin settings.

    Yes ure right.

    Wordpress is installed. On a clean WP installation it works in site and sidebar.

    http://fair-pics.de/

    (Testpage)

    Same settings like on my main page, same Theme like on mainpage.

    Maybe some plugin broke it?

    Should i install all my mainpage plugin also on the testpge and test after every plugin?

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘WP Plugin SAC: Name and comment require. Please complete all required fields …’ is closed to new replies.