Support » Plugin: WP-Matomo Integration (WP-Piwik) » WP-Piwik Settings on Multisite pages doesn’t appear

  • Resolved vanduzled

    (@vanduzled)


    The settings of this plugin doesn’t appear on my Multisite pages under settings or inside the plugins page after the view details. When on an individual WordPress install (not multisite), it appears.

    The link is like this on single WP install: example.com/wp-admin/options-general.php?page=wp-piwik%2Fclasses%2FWP_Piwik.php

    If I use the same link on my: multisite.com/site/wp-admin/options-general.php?page=wp-piwik%2Fclasses%2FWP_Piwik.php

    It would throw a WP error Sorry, you are not allowed to access this page.

    I’m sure that I’m a Super Admin on those sites.

    It wasn’t like this before. Around 1-2 week ago, I can still see the settings page.

    The reason I want to go to the settings page is that I want to fix the connect To Matomo URL because I’m getting 0 stats on some of my pages. Even the ones that I can get stats on, I still cannot see the settings page. I cannot see the settings page on all of my multisite pages.

    Can anyone help? Thanks.

    • This topic was modified 8 months, 2 weeks ago by vanduzled.
    • This topic was modified 8 months, 2 weeks ago by vanduzled.
Viewing 1 replies (of 1 total)
  • Thread Starter vanduzled

    (@vanduzled)

    I have solved the problem. It’s because the plugin is network activate. Disabling this will make the individual pages’ wp-piwik settings visible.

Viewing 1 replies (of 1 total)
  • The topic ‘WP-Piwik Settings on Multisite pages doesn’t appear’ is closed to new replies.