Support » Plugin: WP-Piwik » WP-Piwik Just STOPS Working

  • I have been testing Piwik on a dedicated server since May 2012. I run WordPress sites on THAT server and on several other hosting accounts.

    To date I have had complete success using the WP-Piwik plugin on all the WordPress installations on the dedicated server where the Piwik is installed.

    I have a hosting account with Bluehost (and a second with Gray Webhost, which is a Bluehost reseller). About a month ago the WP-Piwik plugin for 2 very low-traffic Websites running at Gray Webhost stopped working. The Gray Webhost support team worked with me for 2-3 days to confirm that they and Bluehost were NOT in any way blocking the communication between the plugin and the server. No security settings had been changed either in my account or at the hosting level.

    After collecting data for several weeks the plugins for both sites on Gray Webhost simply STOPPED communicating with the Piwik server on my dedicated server.

    Now over the past few days the same problem has cropped up with the Bluehost account. I have five-six low-to-moderate traffic WordPress installations there and all have suddenly stopped communicating with the dedicated server.

    In neither case had I made any changes to any sites, EXCEPT that I normally update plugins and themes whenever I see that updates are available. Of course, I do this for the installations on the dedicated server as well.

    Nearly all sites are configured as WordPress Networks using subdomains. However, I have 1 installation on Bluehost that is NOT configured as network and its plugin has stopped working AND I have 1 installation on the dedicated server and its plugin still works.

    I have a FOURTH hosting account with ZZ Hosting. They, like Bluehost, use cPanel. I have several low-traffic WordPress sites installed there as well. All of them are using the WP-Piwik plugin and all of them are still working fine. I even updated two themes on one of those installations before posting this message and so far the WP-Piwik plugin is still working.

    When the plugin stops working regardless of whether it’s on a network or single installation I get the following error: “An error occured: Piwik did not answer. Please check your entered Piwik URL.”

    My server is NOT suddenly blocking the Bluehost IP address. I control that and I have not blocked that IP address. In fact, I can use another script to connect to the dedicated server just fine.

    I have scanned dozens of WP-Piwik and Piwik support discussions here, at Piwik.Org, and on other forums. These problems are periodically reported going back at least a year. A few people appear to report success in restoring connectivity but most of the error reports are unresolved (or abandoned).

    My dedicated server has been subjected to some brute force hack attempts over the past few months. I have been blocking the proxy IP addresses aggressively through the Linux firewall. The hosting ISP for the dedicated server assures me I have taken all prudent measures to fight off the hackers. The latest WP-Piwik failure does not coincide with any hack attempts. The dedicated server is running fine.

    I originally used the same authorization on all the sites. When this problem first began I created a couple of Piwik user accounts and embedded their authorization codes in a few sites. That makes no difference.

    The Piwik is up-to-date (version 1.8.3), the WP-Piwik is up-to-date (version 0.96), the WordPress is up-to-date (version 3.4.1). On the Bluehost account I switched the PHP from 5.2 to 5.4 (single php.ini) and that made no difference.

    I have deleted all plugins and reinstalled. I have deleted all plugins and just installed WP-Piwik. Makes no difference.

    I cannot find anything in the error logs that points to an issue.

    Does anyone know why Bluehost-based WP-Piwik plugins may suddenly stop communicating with the server? I gave up on Google Analytics in April because it can no longer block crawlers from inflating statistics. Piwik seems to do a much better job of filtering out robots. I really hope there is a simple explanation/solution for all this. Unfortunately I just cannot find it.

Viewing 14 replies - 1 through 14 (of 14 total)
  • For the record, that should have said: “the WP-Piwik is up-to-date (version 0.95)”

    Plugin Author braekling


    Are you using SSL? Have a look at this thread:

    Did you try to run WP-Piwik’s test script and its reset function?
    (See Settings -> WP-Piwik -> Support)

    The test script will show you the target (= Piwik) server’s response.

    Not running SSL.

    Whenever I run the test script it fails to connect to the server. The authorization token is indeed embedded in the settings (you will not see it here). Here is an example report:

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Call: [DOMAIN REMOVED]/?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
    Time: 0.26s
    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Call: [DOMAIN REMOVED]?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=http%3A%2F%2F[DOMAIN REMOVED]&format=XML&token_auth= + TOKEN
    <?xml version="1.0" encoding="utf-8" ?>
    <result />
    Time: 0.39s

    To answer your other question (I apologize for not doing so earlier), I have attempted to reset the settings on several of the sites, both network and standalone installations.

    Prior to failing for good some of the sites had intermittent communication with the server. One minute I would see the reports in the dashboard and the next minute they would be gone.

    I thought perhaps I might have corrupted the plugin for some reason but reinstalling it did not help.

    As of this writing, one of the Bluehost sites is again showing me the reports but the server does not appear to be collecting any data (the traffic has dropped to zero since the weekend).

    Since upgrading the server Piwik to 1.8.3 I get an “Oops – Problem during the request” message. The keywords and external sites widgets fail to load.

    The failure to communicate predates the upgrade to 1.8.3 but I’m afraid I may have corrupted something on the server now and that will complicate the troubleshooting. I’m not sure how to reinstall the 1.8.3 server. Will I lose all data if I simply delete and reinstall from scratch?

    For the record, having done nothing at all, I found a few hours ago that some of the sites have been intermittently capturing data over the past couple of days, but they are still not performing as expected.

    Are there any known issues with plugins that might cause this?

    Plugin Author braekling


    Hi sffandom,

    I updated my live system Piwik some minutes ago to 1.8.3. Seems to work fine here, but I’ll keep watching this.

    Sometimes my Piwik seems to stop counting also. In most cases this is caused by a interrupted auto archiving process, so I run archive.php manually once ( Afterwards counting works fine again and also the missed stats appear.

    If the stats aren’t shown in WordPress, is the tracking code still added properly by WP-Piwik to your WordPress site?

    If I understand aright some sites started working again (before upgrading to 1.8.3) and some don’t? So not-working stats seem to appear by accident?

    If the plugin stops working then the embed code also vanishes. But when the plugin starts working again the embed code comes back.

    Last night I watched my raw server log for the Piwik server on the dedicated machine; I then opened two browsers, one where I was logged in to one of the problem sites (running on a different server) and one where I was not logged in.

    After loading pages in both browsers I got ONE intermittent fetch from the remote Website to the Piwik 1.8.3 server. None of the other attempts went through and the logged in browser showed me that the WP Piwik plugin was reporting errors in the dashboard (could not connect).

    I’m starting to think that maybe Bluehost is just so overloaded it drops the outbound traffic.

    BTW — According to the CPU Throttling report on the cPanel for the Bluehost account, I have been throttled a total of 64 seconds in the past 24 hours. So the CPU is not overburdened. I have no idea of what to do.

    I have tried pinging the Bluehost server from my dedicated machine but they tell me they block pings so that doesn’t provide any information.

    I can fetch pages from the Bluehost machine to my dedicated machine so I have no idea of what to look for.

    Does Piwik use a specific port? I assume that since you were using it before you had the port open. You may want to look into that. Unfortunately that is the only thing I can really think of on this.

    Plugin Author braekling


    Piwik uses HTTP (by default port 80 (http) or 443 (https), otherwise given in the URL).

    I’ll update the test script to show response headers. Maybe it will help us debugging this issue.

    I may have found *MY* problem but I am not sure yet. I have been traveling for a couple of weeks and haven’t had much time to manage my hosting accounts.

    Naturally, everything broke down while I was on the road. It appears my DNS server was corrupt and eventually all my main Websites (including the domain where I host the Piwik server) became inaccessible.

    With my ISP’s help I rebuilt the DNS configuration. All the domains now appear to be visible. And suddenly the WP-Piwik plugins that were not able to reach the Piwik server are starting to collect statistics again. I think they are stable but I’ll have to continue monitoring.

    Plugin Author braekling


    Ok, nice to hear you get this working.

    Can you tell us some details about the corrupt DNS configuration? So maybe other users will be able to identify this problem also.

    Please tell me if the issue occurs again with your working DNS configuration.

    I don’t know what broke with the DNS, which was configured last year after I moved to a new server. When I asked my hosting ISP to look at it they said that some of the settings were wrong so they deleted everything and reconfigured it from scratch.

    The server has been repeatedly attacked by hackers but I don’t know if they have gotten in. We maintain a pretty strict lockdown policy on IP addresses but they can still overwhelm the server with brute force attacks from multiple locations.

    My guess is that one of the brute force attacks may have forced a write to the wrong place on disk, possibly corrupting something. But that is just a wild guess.

    Plugin Author braekling


    Note: 0.9.6 contains an updated test script which delivers additional information (e.g. response headers). The update will be released within the next few days.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘WP-Piwik Just STOPS Working’ is closed to new replies.