Support » Plugin: WP-Matomo (WP-Piwik) » WP-Piwik 1.0.17 was not able to connect to Piwik using your configuration.

  • Paul

    (@mrclean-1)


    https://forum.piwik.org/t/fatal-error-namespace-declaration-statement/13207/3 suggested I talk to my web hosting service, who recommended I upgrade my php from 5.4 to 7.0. I did, and now the error page I see when trying to load Piwik reads, ” Fatal error: Namespace declaration statement has to be the very first statement or after any declare call in the script in /home2/trikala/public_html/piwik/core/Translation/Translator.php on line 27″ (when before just a blank page showed up, so I guess this is a step up).

    These are the results of my test script:

    WP-Piwik 1.0.17
    Mode: http
    
    Test 1/3: global.getPiwikVersion
    
    bool(false)
    
    array(2) {
      [0]=>
      string(140) "HTTP/1.1 200 OK
    Date: Thu, 17 Aug 2017 15:11:35 GMT
    Server: Apache
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8
    
    "
      [1]=>
      string(141) "dontworrymom.com/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 2/3: SitesManager.getSitesWithAtLeastViewAccess
    
    bool(false)
    
    array(2) {
      [0]=>
      string(140) "HTTP/1.1 200 OK
    Date: Thu, 17 Aug 2017 15:11:36 GMT
    Server: Apache
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8
    
    "
      [1]=>
      string(218) "dontworrymom.com/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 3/3: SitesManager.getSitesIdFromSiteUrl
    
    bool(false)
    
    array(2) {
      [0]=>
      string(140) "HTTP/1.1 200 OK
    Date: Thu, 17 Aug 2017 15:11:36 GMT
    Server: Apache
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8
    
    "
      [1]=>
      string(325) "dontworrymom.com/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&urls[2]=method%3DSitesManager.getSitesIdFromSiteUrl%26idSite%3Dn%2Fa%26url%3Dhttp%3A%2F%2Fdontworrymom.com&token_auth=..."
    }
    
    array(2) {
      ["global_settings"]=>
      array(63) {
        ["revision"]=>
        string(10) "2017080901"
        ["last_settings_update"]=>
        string(10) "1502982467"
        ["piwik_mode"]=>
        string(4) "http"
        ["piwik_url"]=>
        string(23) "dontworrymom.com/piwik/"
        ["piwik_path"]=>
        string(30) "http://dontworrymom.com/piwik/"
        ["piwik_user"]=>
        string(0) ""
        ["piwik_token"]=>
        string(3) "set"
        ["auto_site_config"]=>
        string(1) "1"
        ["default_date"]=>
        string(9) "yesterday"
        ["stats_seo"]=>
        string(1) "0"
        ["dashboard_widget"]=>
        string(8) "disabled"
        ["dashboard_chart"]=>
        string(1) "0"
        ["dashboard_seo"]=>
        string(1) "0"
        ["toolbar"]=>
        string(1) "0"
        ["capability_read_stats"]=>
        array(5) {
          ["administrator"]=>
          string(1) "1"
          ["editor"]=>
          string(1) "0"
          ["author"]=>
          string(1) "0"
          ["contributor"]=>
          string(1) "0"
          ["subscriber"]=>
          string(1) "0"
        }
        ["perpost_stats"]=>
        string(1) "0"
        ["plugin_display_name"]=>
        string(8) "WP-Piwik"
        ["piwik_shortcut"]=>
        string(1) "0"
        ["shortcodes"]=>
        string(1) "0"
        ["track_mode"]=>
        string(8) "disabled"
        ["track_codeposition"]=>
        string(6) "footer"
        ["track_noscript"]=>
        string(1) "0"
        ["track_nojavascript"]=>
        string(1) "0"
        ["proxy_url"]=>
        string(0) ""
        ["track_content"]=>
        string(8) "disabled"
        ["track_search"]=>
        string(1) "0"
        ["track_404"]=>
        string(1) "0"
        ["add_post_annotations"]=>
        array(0) {
        }
        ["add_customvars_box"]=>
        string(1) "0"
        ["add_download_extensions"]=>
        string(0) ""
        ["set_download_extensions"]=>
        string(0) ""
        ["set_link_classes"]=>
        string(0) ""
        ["set_download_classes"]=>
        string(0) ""
        ["disable_cookies"]=>
        string(1) "0"
        ["limit_cookies"]=>
        string(1) "0"
        ["limit_cookies_visitor"]=>
        string(8) "34186669"
        ["limit_cookies_session"]=>
        string(4) "1800"
        ["limit_cookies_referral"]=>
        string(8) "15778463"
        ["track_admin"]=>
        string(1) "0"
        ["capability_stealth"]=>
        array(0) {
        }
        ["track_across"]=>
        string(1) "0"
        ["track_across_alias"]=>
        string(1) "0"
        ["track_crossdomain_linking"]=>
        string(1) "0"
        ["track_feed"]=>
        string(1) "0"
        ["track_feed_addcampaign"]=>
        string(1) "0"
        ["track_feed_campaign"]=>
        string(4) "feed"
        ["track_heartbeat"]=>
        string(1) "0"
        ["track_user_id"]=>
        string(8) "disabled"
        ["cache"]=>
        string(1) "1"
        ["http_connection"]=>
        string(4) "curl"
        ["http_method"]=>
        string(4) "post"
        ["disable_timelimit"]=>
        string(1) "0"
        ["connection_timeout"]=>
        string(1) "5"
        ["disable_ssl_verify"]=>
        string(1) "0"
        ["disable_ssl_verify_host"]=>
        string(1) "0"
        ["piwik_useragent"]=>
        string(3) "php"
        ["piwik_useragent_string"]=>
        string(8) "WP-Piwik"
        ["dnsprefetch"]=>
        string(1) "0"
        ["track_datacfasync"]=>
        string(1) "0"
        ["track_cdnurl"]=>
        string(0) ""
        ["track_cdnurlssl"]=>
        string(0) ""
        ["force_protocol"]=>
        string(8) "disabled"
        ["update_notice"]=>
        string(7) "enabled"
      }
      ["settings"]=>
      array(6) {
        ["name"]=>
        string(0) ""
        ["site_id"]=>
        string(3) "n/a"
        ["noscript_code"]=>
        string(0) ""
        ["tracking_code"]=>
        string(0) ""
        ["last_tracking_code_update"]=>
        string(1) "0"
        ["dashboard_revision"]=>
        string(1) "0"
      }
    }
    

    … help, please? I really don’t want to have to run Google Analytics : (.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author braekling

    (@braekling)

    Sorry, but this forum is about the WordPress plugin WP-Piwik. If you need support for Piwik itself, please consider the Piwik forum you already mentioned above: https://forum.piwik.org

    Before you start using the WP plugin, you should make sure Piwik itself is running as expected. The plugin requires a working Piwik setup!

    Btw. to avoid to run into the next issue after Piwik is working: The Piwik URL you entered in the plugin settings is missing the protocol part (http or https).

    Paul

    (@mrclean-1)

    Thanks for the quick reply! I’ll head on to that forum in a sec, but can you first tell me any keywords I should mention there? I wrote this here because Piwik was working before, just it doesn’t seem to be now and the only way I access it is via the WP plugin for it, so it seemed that was what was breaking…

    Hi,

    Got the same problem here with the following debug log:

    WP-Piwik 1.0.17
    Mode: http
    
    Test 1/3: global.getPiwikVersion
    
    bool(false)
    
    array(2) {
      [0]=>
      string(603) "HTTP/1.1 301 Moved Permanently
    Set-Cookie: startBAK=R3415744843; path=/; expires=Wed, 06-Sep-2017 16:06:46 GMT
    Date: Wed, 06 Sep 2017 14:50:14 GMT
    Content-Type: text/html; charset=iso-8859-1
    Content-Length: 250
    Set-Cookie: start=R1548370258; path=/; expires=Wed, 06-Sep-2017 15:57:29 GMT
    Server: Apache
    X-FRAME-OPTIONS: DENY
    X-Content-Type-Options: nosniff
    Strict-Transport-Security: max-age=63072000; includeSubDomains
    Location: https://www.digitemis.com/analytics/piwik/
    Cache-Control: max-age=172800
    Expires: Fri, 08 Sep 2017 14:50:14 GMT
    Vary: Accept-Encoding
    X-IPLB-Instance: 1077
    
    "
      [1]=>
      string(256) "http://www.digitemis.com/analytics/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DVisitsSummary.getUniqueVisitors%26idSite%3Dn%2Fa%26period%3Dday%26date%3Dlast30&urls[1]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 2/3: SitesManager.getSitesWithAtLeastViewAccess
    
    bool(false)
    
    array(2) {
      [0]=>
      string(602) "HTTP/1.1 301 Moved Permanently
    Set-Cookie: startBAK=R3415744843; path=/; expires=Wed, 06-Sep-2017 15:55:22 GMT
    Date: Wed, 06 Sep 2017 14:50:14 GMT
    Content-Type: text/html; charset=iso-8859-1
    Content-Length: 250
    Set-Cookie: start=R1548370258; path=/; expires=Wed, 06-Sep-2017 15:57:29 GMT
    Server: Apache
    X-FRAME-OPTIONS: DENY
    X-Content-Type-Options: nosniff
    Strict-Transport-Security: max-age=63072000; includeSubDomains
    Location: https://www.digitemis.com/analytics/piwik/
    Cache-Control: max-age=172800
    Expires: Fri, 08 Sep 2017 14:50:14 GMT
    Vary: Accept-Encoding
    X-IPLB-Instance: 456
    
    "
      [1]=>
      string(333) "http://www.digitemis.com/analytics/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DVisitsSummary.getUniqueVisitors%26idSite%3Dn%2Fa%26period%3Dday%26date%3Dlast30&urls[1]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[2]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 3/3: SitesManager.getSitesIdFromSiteUrl
    
    bool(false)
    
    array(2) {
      [0]=>
      string(602) "HTTP/1.1 301 Moved Permanently
    Set-Cookie: startBAK=R3415742665; path=/; expires=Wed, 06-Sep-2017 16:03:42 GMT
    Date: Wed, 06 Sep 2017 14:50:14 GMT
    Content-Type: text/html; charset=iso-8859-1
    Content-Length: 250
    Set-Cookie: start=R1548370258; path=/; expires=Wed, 06-Sep-2017 15:54:30 GMT
    Server: Apache
    X-FRAME-OPTIONS: DENY
    X-Content-Type-Options: nosniff
    Strict-Transport-Security: max-age=63072000; includeSubDomains
    Location: https://www.digitemis.com/analytics/piwik/
    Cache-Control: max-age=172800
    Expires: Fri, 08 Sep 2017 14:50:14 GMT
    Vary: Accept-Encoding
    X-IPLB-Instance: 392
    
    "
      [1]=>
      string(442) "http://www.digitemis.com/analytics/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DVisitsSummary.getUniqueVisitors%26idSite%3Dn%2Fa%26period%3Dday%26date%3Dlast30&urls[1]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[2]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&urls[3]=method%3DSitesManager.getSitesIdFromSiteUrl%26idSite%3Dn%2Fa%26url%3Dhttps%3A%2F%2Fwww.digitemis.com&token_auth=..."
    }
    
    array(2) {
      ["global_settings"]=>
      array(63) {
        ["revision"]=>
        string(10) "2017080901"
        ["last_settings_update"]=>
        string(10) "1504709181"
        ["piwik_mode"]=>
        string(4) "http"
        ["piwik_url"]=>
        string(41) "http://www.digitemis.com/analytics/piwik/"
        ["piwik_path"]=>
        string(20) "/www/analytics/piwik"
        ["piwik_user"]=>
        string(0) ""
        ["piwik_token"]=>
        string(3) "set"
        ["auto_site_config"]=>
        string(1) "1"
        ["default_date"]=>
        string(5) "today"
        ["stats_seo"]=>
        string(1) "1"
        ["dashboard_widget"]=>
        string(6) "last30"
        ["dashboard_chart"]=>
        string(1) "1"
        ["dashboard_seo"]=>
        string(1) "1"
        ["toolbar"]=>
        string(1) "1"
        ["capability_read_stats"]=>
        array(5) {
          ["administrator"]=>
          string(1) "1"
          ["editor"]=>
          string(1) "0"
          ["author"]=>
          string(1) "0"
          ["contributor"]=>
          string(1) "0"
          ["subscriber"]=>
          string(1) "0"
        }
        ["perpost_stats"]=>
        string(1) "1"
        ["plugin_display_name"]=>
        string(8) "WP-Piwik"
        ["piwik_shortcut"]=>
        string(1) "0"
        ["shortcodes"]=>
        string(1) "0"
        ["track_mode"]=>
        string(7) "default"
        ["track_codeposition"]=>
        string(6) "footer"
        ["track_noscript"]=>
        string(1) "0"
        ["track_nojavascript"]=>
        string(1) "0"
        ["proxy_url"]=>
        string(0) ""
        ["track_content"]=>
        string(8) "disabled"
        ["track_search"]=>
        string(1) "1"
        ["track_404"]=>
        string(1) "1"
        ["add_post_annotations"]=>
        array(0) {
        }
        ["add_customvars_box"]=>
        string(1) "0"
        ["add_download_extensions"]=>
        string(0) ""
        ["set_download_extensions"]=>
        string(0) ""
        ["set_link_classes"]=>
        string(0) ""
        ["set_download_classes"]=>
        string(0) ""
        ["disable_cookies"]=>
        string(1) "0"
        ["limit_cookies"]=>
        string(1) "0"
        ["limit_cookies_visitor"]=>
        string(8) "34186669"
        ["limit_cookies_session"]=>
        string(4) "1800"
        ["limit_cookies_referral"]=>
        string(8) "15778463"
        ["track_admin"]=>
        string(1) "0"
        ["capability_stealth"]=>
        array(0) {
        }
        ["track_across"]=>
        string(1) "0"
        ["track_across_alias"]=>
        string(1) "0"
        ["track_crossdomain_linking"]=>
        string(1) "0"
        ["track_feed"]=>
        string(1) "0"
        ["track_feed_addcampaign"]=>
        string(1) "0"
        ["track_feed_campaign"]=>
        string(4) "feed"
        ["track_heartbeat"]=>
        string(1) "0"
        ["track_user_id"]=>
        string(8) "disabled"
        ["cache"]=>
        string(1) "1"
        ["http_connection"]=>
        string(4) "curl"
        ["http_method"]=>
        string(4) "post"
        ["disable_timelimit"]=>
        string(1) "0"
        ["connection_timeout"]=>
        string(1) "5"
        ["disable_ssl_verify"]=>
        string(1) "0"
        ["disable_ssl_verify_host"]=>
        string(1) "0"
        ["piwik_useragent"]=>
        string(3) "php"
        ["piwik_useragent_string"]=>
        string(8) "WP-Piwik"
        ["dnsprefetch"]=>
        string(1) "0"
        ["track_datacfasync"]=>
        string(1) "0"
        ["track_cdnurl"]=>
        string(0) ""
        ["track_cdnurlssl"]=>
        string(0) ""
        ["force_protocol"]=>
        string(8) "disabled"
        ["update_notice"]=>
        string(7) "enabled"
      }
      ["settings"]=>
      array(6) {
        ["name"]=>
        string(0) ""
        ["site_id"]=>
        string(3) "n/a"
        ["noscript_code"]=>
        string(0) ""
        ["tracking_code"]=>
        string(0) ""
        ["last_tracking_code_update"]=>
        string(10) "1504709181"
        ["dashboard_revision"]=>
        string(1) "0"
      }
    }

    Any suggestion to debug ?

    Plugin Author braekling

    (@braekling)

    @fanchyfanch The same problem? You are talking about namespace errors caused by Piwik? In this case please have a look at my previous answer:

    Sorry, but this forum is about the WordPress plugin WP-Piwik. If you need support for Piwik itself, please consider the Piwik forum you already mentioned above: https://forum.piwik.org

    https://wordpress.org/support/topic/wp-piwik-1-0-17-was-not-able-to-connect-to-piwik-using-your-configuration/#post-9419557

    But your debug code shows a different problem and contains already everything you need to debug: Your webserver running Piwik answers “HTTP/1.1 301 Moved Permanently” which means a redirect. You should always connect to Piwik directly without any redirects. Looking at your URL shows that you are trying to connect via HTTP, but your server always redirects to HTTPS. So it should solve the issue to change the protocol to https.

    Tomas Risberg

    (@tomasrisbergsilentse)

    Hi,

    I have just discovered Piwik and now have a working installation of it in the same public_html directory as WordPress.

    But I also have this problem connecting WP-Piwik to Piwik. I enclose my test script.

    Can anyone here help me understand if the 403 error occurs because of a setting in WordPress or does it come from a server setting? Can I fix it myself or do I have to talk to my ISP?

    Tomas Risberg

    This is my debug log:

    WP-Piwik 1.0.17
    Mode: http
    
    Test 1/3: global.getPiwikVersion
    
    bool(false)
    
    array(2) {
      [0]=>
      string(234) "HTTP/1.1 403 Forbidden
    Date: Sat, 16 Sep 2017 07:03:22 GMT
    Server: Apache
    Vary: accept-language,accept-charset
    Accept-Ranges: bytes
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=iso-8859-1
    Content-Language: en
    
    "
      [1]=>
      string(149) "http://exp.silent.se/analytics/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 2/3: SitesManager.getSitesWithAtLeastViewAccess
    
    bool(false)
    
    array(2) {
      [0]=>
      string(234) "HTTP/1.1 403 Forbidden
    Date: Sat, 16 Sep 2017 07:03:22 GMT
    Server: Apache
    Vary: accept-language,accept-charset
    Accept-Ranges: bytes
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=iso-8859-1
    Content-Language: en
    
    "
      [1]=>
      string(226) "http://exp.silent.se/analytics/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 3/3: SitesManager.getSitesIdFromSiteUrl
    
    bool(false)
    
    array(2) {
      [0]=>
      string(234) "HTTP/1.1 403 Forbidden
    Date: Sat, 16 Sep 2017 07:03:22 GMT
    Server: Apache
    Vary: accept-language,accept-charset
    Accept-Ranges: bytes
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=iso-8859-1
    Content-Language: en
    
    "
      [1]=>
      string(330) "http://exp.silent.se/analytics/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&urls[2]=method%3DSitesManager.getSitesIdFromSiteUrl%26idSite%3Dn%2Fa%26url%3Dhttp%3A%2F%2Fexp.silent.se&token_auth=..."
    }
    
    array(2) {
      ["global_settings"]=>
      array(63) {
        ["revision"]=>
        string(10) "2017080901"
        ["last_settings_update"]=>
        string(10) "1505545370"
        ["piwik_mode"]=>
        string(4) "http"
        ["piwik_url"]=>
        string(31) "http://exp.silent.se/analytics/"
        ["piwik_path"]=>
        string(0) ""
        ["piwik_user"]=>
        string(0) ""
        ["piwik_token"]=>
        string(3) "set"
        ["auto_site_config"]=>
        string(1) "1"
        ["default_date"]=>
        string(9) "yesterday"
        ["stats_seo"]=>
        string(1) "0"
        ["dashboard_widget"]=>
        string(8) "disabled"
        ["dashboard_chart"]=>
        string(1) "0"
        ["dashboard_seo"]=>
        string(1) "0"
        ["toolbar"]=>
        string(1) "0"
        ["capability_read_stats"]=>
        array(5) {
          ["administrator"]=>
          string(1) "1"
          ["editor"]=>
          string(1) "0"
          ["author"]=>
          string(1) "0"
          ["contributor"]=>
          string(1) "0"
          ["subscriber"]=>
          string(1) "0"
        }
        ["perpost_stats"]=>
        string(1) "0"
        ["plugin_display_name"]=>
        string(8) "WP-Piwik"
        ["piwik_shortcut"]=>
        string(1) "0"
        ["shortcodes"]=>
        string(1) "0"
        ["track_mode"]=>
        string(8) "disabled"
        ["track_codeposition"]=>
        string(6) "footer"
        ["track_noscript"]=>
        string(1) "0"
        ["track_nojavascript"]=>
        string(1) "0"
        ["proxy_url"]=>
        string(0) ""
        ["track_content"]=>
        string(8) "disabled"
        ["track_search"]=>
        string(1) "0"
        ["track_404"]=>
        string(1) "0"
        ["add_post_annotations"]=>
        array(0) {
        }
        ["add_customvars_box"]=>
        string(1) "0"
        ["add_download_extensions"]=>
        string(0) ""
        ["set_download_extensions"]=>
        string(0) ""
        ["set_link_classes"]=>
        string(0) ""
        ["set_download_classes"]=>
        string(0) ""
        ["disable_cookies"]=>
        string(1) "0"
        ["limit_cookies"]=>
        string(1) "0"
        ["limit_cookies_visitor"]=>
        string(8) "34186669"
        ["limit_cookies_session"]=>
        string(4) "1800"
        ["limit_cookies_referral"]=>
        string(8) "15778463"
        ["track_admin"]=>
        string(1) "0"
        ["capability_stealth"]=>
        array(0) {
        }
        ["track_across"]=>
        string(1) "0"
        ["track_across_alias"]=>
        string(1) "0"
        ["track_crossdomain_linking"]=>
        string(1) "0"
        ["track_feed"]=>
        string(1) "0"
        ["track_feed_addcampaign"]=>
        string(1) "0"
        ["track_feed_campaign"]=>
        string(4) "feed"
        ["track_heartbeat"]=>
        string(1) "0"
        ["track_user_id"]=>
        string(8) "disabled"
        ["cache"]=>
        string(1) "1"
        ["http_connection"]=>
        string(4) "curl"
        ["http_method"]=>
        string(4) "post"
        ["disable_timelimit"]=>
        string(1) "0"
        ["connection_timeout"]=>
        string(1) "5"
        ["disable_ssl_verify"]=>
        string(1) "0"
        ["disable_ssl_verify_host"]=>
        string(1) "0"
        ["piwik_useragent"]=>
        string(3) "php"
        ["piwik_useragent_string"]=>
        string(8) "WP-Piwik"
        ["dnsprefetch"]=>
        string(1) "0"
        ["track_datacfasync"]=>
        string(1) "0"
        ["track_cdnurl"]=>
        string(0) ""
        ["track_cdnurlssl"]=>
        string(0) ""
        ["force_protocol"]=>
        string(8) "disabled"
        ["update_notice"]=>
        string(7) "enabled"
      }
      ["settings"]=>
      array(6) {
        ["name"]=>
        string(0) ""
        ["site_id"]=>
        string(3) "n/a"
        ["noscript_code"]=>
        string(0) ""
        ["tracking_code"]=>
        string(0) ""
        ["last_tracking_code_update"]=>
        string(1) "0"
        ["dashboard_revision"]=>
        string(1) "0"
      }
    }
    
    Tomas Risberg

    (@tomasrisbergsilentse)

    Hi,

    Since no one else has responded here, and I haven’t yet figured out how to make WP-Piwik connect with Piwik, I add some more data:

    I have tested connecting WP-Piwik with Piwik without any other WP plugins. I have tested connecting WP-Piwik with Piwik without any .htaccess at all. I have talked to my ISP. I have asked them if there is some problem with connecting to local host, but they have not yet returned with an answer. They are quite reluctant to help, because they think it’s a WordPress Plug-In-problem, and not their problem.

    My Piwik installation works perfect in its analytics folder in the same public_html directory as my WP installation, but WP-Piwik will not connect to Piwik.

    One thing that grasped my attention, talking about local host, is that Piwik prefills a local host connection, but this one doesn’t work to connect Piwik to the MySql database. Does this indicate that there is some problem connected with local host here?

    It occurred to me that having Piwik in the same public_html as a WordPress installation is similar to have two WordPress-installations in the same public_html directory. So I searched for that to try to find a solution, and found this:

    http://www.dinelogik.com/mbstrategic/11/install-wordpress-as-subdirectory-of-another-wordpress-installation-two-wordpress-installations-one-domain/

    Can anything in that article be used to connect WP-Piwik with Piwik, when Piwik resides in the same public_html as WordPress?

    Tomas Risberg

    Tomas Risberg

    (@tomasrisbergsilentse)

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.