Support » Plugin: WP-Matomo Integration (WP-Piwik) » WP-Piwik 1.0.15: Website switches to https

  • Resolved gerobe

    (@gerobe)


    Hello,

    since version 1.0.15 my website, when called with http, always redirects to the https-version. I know, that this might be a conflict with another plugin like WordPress HTTPS, but due to the fact, that this problem did not appear with version 1.0.14 it definitely seems to be a bug or a change in version 1.0.15 that causes the protocol to switch to https. As soon as I downgraded to version 1.0.14 the problem disappeared and the protocol remained http.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author braekling

    (@braekling)

    Hm, I had a look at the changes I did for 1.0.15, but I can’t identify which changes may cause such a behavior.

    Are you using the proxy tracking code? Most changes were related to this.

    Are you connecting to Piwik via HTTP or PHP?

    Thread Starter gerobe

    (@gerobe)

    I haven’t used the proxy-code. I connected via http(s) and changed it now to php. Both methods do work with 1.0.14. They both also work with 1.0.15, except that the whole website redirects to https and no http connection is possible.

    Plugin Author braekling

    (@braekling)

    Hm, sorry, but I can’t find a hint how WP-Piwik may cause a redirect. Especially related to the latest updated.

    Are you using the WordPress proxy settings (this is not related to the proxy tracking code)? There I also made a small change.

    Did you also try to disable other plugins? Maybe WP-Piwik 1.0.15 is somehow causing a side effect?

    Thread Starter gerobe

    (@gerobe)

    Don’t ask me why, I’m not that deep into session programming, but my theme had a php session-command in the header ini_set('session.use_trans_sid', false);

    This produced a (normally not displayed) php warning, that no session commands a possible, because a session is already set.

    I just commented out that command in my theme and the warning was gone.

    Now I updated to WP-Piwik 1.0.15 and everything seems to be ok. No forced redirect to https anymore.

    I have no idea, if WP-Piwik or any other plugin caused that warning, but with the warning (and the session-command) gone, everything seems to work now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP-Piwik 1.0.15: Website switches to https’ is closed to new replies.