WordPress.org

Support

Support » Plugins and Hacks » WP Photos Plugin

WP Photos Plugin

Viewing 15 replies - 1 through 15 (of 98 total)
  • Hmm, all I get is:
    “Whoops, some error occured. Bummer, huh?” after trying to create the DB entries. Any suggestions what might be wrong? :-). What should I be changing in \plugins\wp-photos.php?
    Thanks,
    Ben

    You need to load the plugin before running the installer, as I just discovered.

    Ah, that did it. The first step in the readme is wrong, kind of. It says:
    “1) Put everything (except this README.txt file) from the zip file into your blog directory.
    http://www.example.com/blog/ <– everything in there”,
    but then later on says that plugins should be in the wp-content director. I just missed the wp-content part for the plugins direcoty.
    Ben

    Alex, What is the cleanest way to right-align the preview photo and have the text wrap around the left of the photo?

    hmm, i don’t get the add button or link to show up…

    jhorner – You can do the alignment through the CSS classes.

    can you please provide the sql file separately? please.

    I cannot choos the image I want, because it doesn’t show the images inside the folders and it says:
    No suitable folders found.
    what is the problem?

    The SQL is in the install script.
    If no suitable folders are found, it probably means you haven’t uploaded the photos in the structure explained in the README.

    Sorry, I just posted this as a comment in your Blog, before I realised support issues should go here..
    I was getting an “access denied to user wwwrun� message. I gave wwwrun SELECT acess on my WP database.
    However, I am now getting:
    Warning: mysql_fetch_object(): supplied argument is not a valid MySQL result resource in /home/raid/httpd/htdocs/ianblog/wp-content/plugins/wp-photos.php on line 193
    Database error: [No Database Selected]
    I would guess that I have either missed something very obvious in the config, or it isn’t picking up my database settings.
    Ian.

    Loading things as in the readme ..
    made a directory called as Told like so…
    http://www.mysite.com/blog/
    put folder contents inside the directory as said in number one
    1) Put everything (except this README.txt file) from the zip file into your blog directory.
    http://www.example.com/blog/ <– everything in there
    now i have the folowing scenario
    wp-photo.php
    wp-photos-installer.php
    wp-photos-manager.php
    Folder= plugins
    Folder= wp-photos
    but in number one in the ReadMe gives an example of how it spose to be aslike follows..

    http://www.example.com/blog/wp-photos/
    http://www.example.com/blog/wp-photo.php
    http://www.example.com/blog/wp-photos-manager.php
    http://www.example.com/blog/wp-photos-installer.php
    http://www.example.com/blog/wp-content/plugins/wp-photos.php

    so in that last example you notice i have to create the directory wp-content within “blog” in order to follow that example..
    done..
    moved the contents of the plugins folder along with the folder becouse now i supose its to be moved within this blog/wp-content/plugins
    example…
    was i wrong to assume this?
    becouse for one i get an error in the install and i dont get the plugin showing at all in admn plugins manager, so i cant even activate it..
    (placing content in the plugins folder along with all the other plugins that came by default in the root/wp-content/plugins/ brings the photo thing to show up, but i wasnt told in the example that this is suposed to happen, and it didnt change the error in the install ..)
    anyway..to make this all short..how in the world did anyone get theres running following these examples…?
    btw what inside the file..
    blog/wp-photos/wp-photos.php is to be changed “as needed”????
    is this supose to help this scenario…
    oh and the error i get durring install is this..
    Warning: main(wp-blog-header.php): failed to open stream: No such file or directory in/mysite/blog/wp-photos-installer.php on line 4
    Fatal error: main(): Failed opening required ‘wp-blog-header.php’ (include_path=’.:/usr/local/lib/php’)in/mysite/blog/wp-photos-installer.php on line 4
    can anyone help me clear this misunderstanding up?
    you can understand im a bit frutrated after bangen around with this..
    sorry to sound abit errrr in all this..i couldnt get any clues much in any of the post besides the readme..
    zing

    igb: All I do is include wp-blog-header.php in the files, this establishes the database connection. Are you running WP 1.2?
    Zing: it sounds like you aren’t running WordPress 1.2. This is a plugin for 1.2.

    What do you mean that you need to load the plugin before running the installer?
    I uploaded everything, but am still getting the “Whoops, some error occured. Bummer, huh?” when I try to create the table. Can anyone tell me what I am doing wrong?

    All I do is include wp-blog-header.php in the files, this establishes the database connection. Are you running WP 1.2?

    Yes, I am. Everything else in the Blog works OK, so it’s probably something simple I have overlooked. I go through all my settings when the children are in bed:)
    Ian.

    You have to activate the plugin before running the install script.

Viewing 15 replies - 1 through 15 (of 98 total)
  • The topic ‘WP Photos Plugin’ is closed to new replies.
Skip to toolbar