Support » Plugins and Hacks » WP Photos Hack (1.0 Compatible)

WP Photos Hack (1.0 Compatible)

Viewing 15 replies - 16 through 30 (of 60 total)
  • hello,
    i can find “- this goes just in front of <?php the_content(); ?>”,
    but cannot find the place “-this goes before the comments”.
    where is “before comments”?
    just tell me the line number.
    thank you.

    Can’t seem to get this thing working either. Uploaded everything, created table (after deleting the /* font-family: verdana; */ string), tried to put all the stuff in the right place in the index.php.
    There still is no edit/add image link in the admin-screens… Maybe “<?php
    if (isset($c) && $c == 1) {
    $photos = get_post_photos($id);
    $photos = get_thumbnail_grid($photos);
    is not at the right place?
    Please help.

    Oops, it works! in the edit screen! Thanks for this great script! Paul

    I noticed a typo in wp-photos.php @ line 41
    if ($b2photos->import_IPTC == 1) {
    Should be $wpphotos->

    I’ve got everything loaded, worked out the bugs and issues, but don’t see anything.

    What is wrong if it says “No suitable folders found” when I try to select the folder with the photos in it (after clicking on “Photos: Add” in the edit page)? It is set up exactly as described in the readme, and I am stumped. The folder shows up, but then when I try to select it I get this error.

    Thanks Jim, I’ll fix that.
    redneck, what do you expect to see?
    litlnemo, usually that means the folders and files aren’t arranged as required. Does it work with the included sample photo?

    Um. I’m a dork because I deleted the sample after I added my own folder. The folder(s) I added were exactly the same — in the wp-photos folder, I placed a folder called “test” containing the full-size jpegs, and inside the “test” folder, a folder called “t” with the thumbnail jpegs. Since everything seemed correct I was an idiot and deleted the sample folder without actually trying it. I wonder if I still have a copy here somewhere….
    Anyway, this is the current set-up:
    wp-photos folder in my blog’s directory
    test folder in the wp-photos folder
    t folder in the test folder
    That’s correct, right?
    Is there any specific permissions setting I should give the folders?

    Hmm. I found the sample folder in the original archive I downloaded, and put it back in its place on the server. I still get the same error.

    Alex: “what did I expect to see?”
    From the README: “Then click the Add link next to a post and click the (Use ->) link next to your folder.”

    redneck, If you don’t have Photo Add?Edit links as shown in the screenshot here:
    Then something isn’t set up properly.
    litlnemo, check your permissions I guess. It works when everything is in place.

    No, I don’t see that text (you can check my site). There’s nothing in the page source either.
    I fool around with my category, so there is never a case where there is no category selected (forces $c to 1 if no $c is set). I don’t know whether that would screw up your !isset($c) || $c != 1) test. Also, your !empty($photo->thumb) texst might fail, since all I have in there is the one sample that came with your download.
    Not a big deal at the moment. I just thought I would try it. I have other fish to fry for now.

    you are looking in the admin area, right?

    Oops, um, yay, it works!

    Alex, is there any specific permissions setting I should give the folders? I did chmod 766 on them. Then I was getting the error “Warning: stat failed for wp-photos/sample/t/t (errno=13 – Permission denied) in (path to my blog directory)/wp-photos.hack.php on line 263” and the same error on line 289. I loosened up the permissions more and got that to go away, and now I am getting the “No suitable folders found” error again. I am stumped. I am not fluent enough in php to know why it is telling me this.
    (further messing around with it…)
    Ooooookay… I got the sample to work. The other folder with my own images still doesn’t work…
    (further messing around)
    I think I have figured it out. There were two problems — the permissions problem (which wasn’t happening at first), and then another one. The problem seems to have been that the thumbnails did not have the exact same name as the big pics. This may seem obvious to you that they should, but not to me (never having used the script before, I didn’t know if I was going to have to choose the thumbnails directly for each image or what — I didn’t assume the script would know them automatically). 🙂 So now that I gave them both the same name I can look in the folder. It’s a bit of a pain since I always store thumbnails with a different name, by habit…
    (further messing around)
    Oh hell. It still doesn’t work. Says it’s adding the images to “post #128” but they aren’t there. They aren’t showing up in the source, even. I think I am giving up for now.

Viewing 15 replies - 16 through 30 (of 60 total)
  • The topic ‘WP Photos Hack (1.0 Compatible)’ is closed to new replies.