WordPress.org

Support

Support » How-To and Troubleshooting » WP permalinks doesnt work Help!!!

WP permalinks doesnt work Help!!!

  • I have a big problem guys, i think its time to ask my wordpress problem here, I.T. forums doesnt know how to fix my problem.
    I have blog with a good traffic.. that makes my current webhost to complain, they suggest to upgrade my current webhost account into a VPS to handle my traffic.

    So my site is now using a VPS account, CP+ 3.1.1. as a site controller.., but i have a problem, when i restore my previous site post backups to this VPS account. PERMALINKS doesnt work anymore.. I dunno why.

    I try everything… I have my .htaccess writable and chmod it into 777..
    i chmod also the following directories and files wp-content, themes, theme files, plugins, wp-config.php into 777.
    I check my httpd.conf , mod_rewrite is enable.. so whats the problem?

    What must I do? heres the link from my VPS account http://207.210.112.152/
    just check it out..

    my permalinks from my category pages, and single page doesnt work.. i don’t want to use the default permalink index.php?w=123 type coz my current long file and customize permalink gives me a high ranking in google, yahoo etc.

    Please help me.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    What is the content of the .htaccess file? Have you tried updating the permalinks?

    abondanzieri
    Member

    @abondanzieri

    i have the same problem.

    can somebody help?

    Chris_K
    Member

    @handysolo

    Much troubleshooting at the Permalinks page.

    In particular, ensure your host has mod_rewrite and AllowOverrides probably on and enabled.
    Then make sure your .htaccess is being updated. Pay attention when on the Options -> Permalinks page: If WP can’t write to the file, it’ll tell YOU want to add.

    I’m facing the same with 2.1.2

    Permalink changes from WordPress doesn’t work. Although the relevent files are writable, and WP shows “permission changed” message.

    Well, it’s fixed now…
    But I need to go through mod_rewrite problem now then. 🙂

    abondanzieri
    Member

    @abondanzieri

    so how do i change AllowOverrides to On ?

    Chris_K
    Member

    @handysolo

    On servers I own/manage I’d do it in apache config.

    If you don’t own the box, have your host check.

    abondanzieri
    Member

    @abondanzieri

    i am trying to figure it out on my localhost.. so i own it..

    where is apache config ?

    thank you for your interest.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP permalinks doesnt work Help!!!’ is closed to new replies.