[resolved] WP-PageNavi not working with Theme Simplify (5 posts)

  1. visanu
    Posted 2 years ago #

    Hi ,

    I am using Theme Simplify with wp-pagenavi and its not working.

    What I did is that I have replaced the code `<div class="alignleft"><?php previous_posts_link('« Previous Entries') ?></div>
    <div class="alignright"><?php next_posts_link('Next Entries »','') ?></div>` with
    <?php wp_pagenavi(); ?> in my theme's index.php file and doesnt showing up.

    Please guide me.


  2. Michael
    Part-Time Forum Moderator
    Posted 2 years ago #

    might be a formatting problem;


    <div class="alignright"><?php wp_pagenavi(); ?></div>

    or have a look into the html code of your site in the browser ('View Source' or similar) to see if you can find the output of wp-pagenavi.

    or post a link to your site so somebody can check that for you.

  3. visanu
    Posted 2 years ago #

    Yeah its working now..I am using that code on wrong page. Thanks for the guidance.

    I used this code <?php wp_pagenavi(); ?> on my single.php and on page.php.

    I am having a total of 2 pages and there are soo many posts.

    But on both single.php and page.php it is showing in a box Page 1 of 1 .

    why this so?

    I want to see it something as in this screenshot for so many pages
    Please guide.

    Thanks !

  4. visanu
    Posted 2 years ago #

    Also how do I add this code wp_pagenavi(); on my folloiwng category page:


    Any idea please ?

  5. visanu
    Posted 2 years ago #


    My issue have been resolved.

    I have added the code on my archive.php.

    The issue can be closed now. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic