Support » Plugin: WP-PageNavi » WP-PageNavi Issue with Elegant Theme after WP 3.4.1 Update

Viewing 4 replies - 1 through 4 (of 4 total)
  • Elegant Themes discovered a solution. Stay tuned …

    Hi @ericreynolds007
    I am using the same theme with WP pagenavi and it does not work for me.
    Would you be kind enough to tell me how were you able to make it work

    Hi Kishor. The conflicting plugin for the home page pagination issue was Simply Exclude, a plugin that excludes or includes taxonomies.

    I still had the issue with category pages. Page 2 and 3 displayed “No Results Found” each time I selected the WP-PageNavi links.

    I disabled all of my plugins, other than WP-PageNavi, and the pagination worked like a charm. I activated each plugin one-by-one, testing the pagination each time I enabled a plugin. To my dismay, the WordPress SEO by Yoast plugin was at fault.

    My entire site is optimized through WordPress SEO! Fortunately, I discovered that by disabling a single plugin function, “Strip the category base (usually /category/ from category URL,” my pagination worked and I could keep the SEO plugin activated. The option is located at Dashboard > SEO > Permalinks

    But, what about the “category” path in my URL? I didn’t want it there. I remembered that I used a plugin called “WP No Category Base – WPML compatible” that stripped “category” from my URLs. Fortunately, the plugin developer is active and the plugin is WP 3.4.1 compatible.

    I installed and activated the plugin and surfed my site. End of story? Everything works and looks good!

    I hope this helps.

    🙂 Eric

    thanks eric, I dont have wordpress SEO plugin yet..
    but ill also go one at a time on my plugin to see which one is causing it


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP-PageNavi Issue with Elegant Theme after WP 3.4.1 Update’ is closed to new replies.