Support » Fixing WordPress » WP Page name “Index” result in 404 Error

  • Resolved Rob

    (@rob70)


    I create in WP an menu/page named “Index”
    When I view my page URL https://domain.com/index/
    Resulting in Error 404 (The page you are looking for cannot be found)…
    When I view my other pages, is all OK
    Only the page name “Index” give problems

    QST Is there a option to allowed the use of “Index” as a page name?

    Thx Robert (PL)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Joy

    (@joyously)

    I tried it in WP 5.3.2, and it works fine.
    You can try using the Health Check plugin in Troubleshoot mode, to disable plugins for your user only, to see if any of them are causing the problem.

    Thread Starter Rob

    (@rob70)

    Hi Joy, thanks for your reply
    Running WP 5.3.2 to.
    I disable all my plugin’s, Error 404
    I de-activate all my plugin’s, Error 404
    It appears that the name “Index” is being blocked
    My websites running on Synology server (DS118)
    I try it on other Synology servers same result
    Will bring this issue in the Synology Community (Forum)
    Thanks for your support.
    Robert (PL)

    Thread Starter Rob

    (@rob70)

    By changing Permalink > Common Settings > “Day and name” > “Plain text”
    The name “Index” is replace by “PAGE ID Numbers”
    From here it is working BUT I prefer using “Day and name”
    Still looking for an solution
    Robert (PL)

    • This reply was modified 1 year, 1 month ago by Rob.
    Joy

    (@joyously)

    OK, I can see your confusion. The Permalinks setting is for Posts, not Pages.
    Pages always have the same permalink: domain/page-name.

    Thread Starter Rob

    (@rob70)

    Hello Joy
    Thanks for understanding it is an NAS/Server issue
    I already bring it up to Synology support
    For now I name the page Index for the URL indexed
    Thanks Robert (PL)

    Thread Starter Rob

    (@rob70)

    Running my websites on an Synology DS118 Server. The Synology wordpress package version 5.2.4-0153 is supporting Apache HTTP Server 2.2 and PHP 7.2, In this configuration when I create page / menu “Index” is allowed and working normal.

    I am using the latest WordPress downloaded version 5.3.2 > Maria database 10 (127.0.0.1:3307) > Apache HTTP Server 2.4 > PHP 7.3. In this configuration when I create an page / menu name “Index” it generate the Error 404 (The page you are looking for cannot be found)

    I prefer to run my WordPress websites with latest version 5.3.2 mains
    I have to name the page “Index” for the URL “indexed”

    Thx Robert (PL)

    • This reply was modified 1 year, 1 month ago by Rob.
    • This reply was modified 1 year, 1 month ago by Rob.
    • This reply was modified 1 year, 1 month ago by Rob.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP Page name “Index” result in 404 Error’ is closed to new replies.