Support » Plugin: WP-Optimize - Clean, Compress, Cache. » WP-Optimize 3.0.18

  • Resolved marcophile

    (@marcophile)


    Hello
    I cannot use the new version 3.0.18, it displays Loading data … for an hour
    Thank you for your help

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Support Marc Lacroix

    (@marcusig)

    Hi there,

    Can you open your browser console (how to do it), then reload the page to see if it shows an error?

    Best,
    Marc.

    Anonymous User 12851872

    (@anonymized-12851872)

    Hi,
    I just made the update on two sites, same problem “Loading data …” which turns, again and again.

    VM625:1 Uncaught SyntaxError: Unexpected number
        at Object.format (wpoadmin-3-0-18.min.js?ver=3.0.18:1)
        at Object.getParsedText (jquery.tablesorter.min.js?ver=3.0.18:1)
        at Object.buildCache (jquery.tablesorter.min.js?ver=3.0.18:1)
        at Object.commonUpdate (jquery.tablesorter.min.js?ver=3.0.18:1)
        at Object.updateAll (jquery.tablesorter.min.js?ver=3.0.18:1)
        at HTMLTableElement.<anonymous> (jquery.tablesorter.min.js?ver=3.0.18:1)
        at HTMLTableElement.dispatch (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3)
        at HTMLTableElement.r.handle (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3)
        at Object.trigger (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3)
        at Object.a.event.trigger (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:8)
    format @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    getParsedText @ jquery.tablesorter.min.js?ver=3.0.18:1
    buildCache @ jquery.tablesorter.min.js?ver=3.0.18:1
    commonUpdate @ jquery.tablesorter.min.js?ver=3.0.18:1
    updateAll @ jquery.tablesorter.min.js?ver=3.0.18:1
    (anonymous) @ jquery.tablesorter.min.js?ver=3.0.18:1
    dispatch @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    r.handle @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    a.event.trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:8
    (anonymous) @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    update_tables_list @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    (anonymous) @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    success @ send-command-3-0-18.min.js?ver=3.0.18:1
    i @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    fireWith @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    x @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:4
    c @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:4
    XMLHttpRequest.send (async)
    send @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:4
    ajax @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:4
    wp_optimize.send_command @ send-command-3-0-18.min.js?ver=3.0.18:1
    get_database_tabs @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    (anonymous) @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    dispatch @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    r.handle @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    a.event.trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:8
    (anonymous) @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    (anonymous) @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    dispatch @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    r.handle @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    a.event.trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:8
    (anonymous) @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    trigger @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3
    (anonymous) @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    setTimeout (async)
    WP_Optimize @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    (anonymous) @ wpoadmin-3-0-18.min.js?ver=3.0.18:1
    i @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    fireWith @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    ready @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    J @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:2
    VM627:1 Uncaught SyntaxError: Unexpected number
        at Object.format (wpoadmin-3-0-18.min.js?ver=3.0.18:1)
        at Object.getParsedText (jquery.tablesorter.min.js?ver=3.0.18:1)
        at Object.buildCache (jquery.tablesorter.min.js?ver=3.0.18:1)
        at Object.commonUpdate (jquery.tablesorter.min.js?ver=3.0.18:1)
        at Object.updateAll (jquery.tablesorter.min.js?ver=3.0.18:1)
        at HTMLTableElement.<anonymous> (jquery.tablesorter.min.js?ver=3.0.18:1)
        at HTMLTableElement.dispatch (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3)
        at HTMLTableElement.r.handle (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3)
        at Object.trigger (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:3)
        at Object.a.event.trigger (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3.2:8)

    here are the errors

    Cette page utilise la propriété non standard « zoom ». Envisagez d’utiliser calc() dans les valeurs des propriétés pertinentes ou utilisez « transform » avec « transform-origin: 0 0 ». admin.php
    SyntaxError: unexpected token: numeric literal
    2 wpoadmin-3-0-18.min.js:1:2
    Descripteur « / » inconnu dans la règle @font-face.  Passage à la déclaration suivante. admin.php:102:111
    Propriété « speak » inconnue.  Déclaration abandonnée. load-styles.php:2:34566
    Propriété « -moz-osx-font-smoothing » inconnue.  Déclaration abandonnée. load-styles.php:2:34694
    Propriété « -moz-osx-font-smoothing » inconnue.  Déclaration abandonnée. load-styles.php:4:429
    Propriété « speak » inconnue.  Déclaration abandonnée. load-styles.php:4:4216
    Propriété « -moz-osx-font-smoothing » inconnue.  Déclaration abandonnée. load-styles.php:4:4294
    Propriété « speak » inconnue.  Déclaration abandonnée. load-styles.php:4:6390
    Propriété « -moz-osx-font-smoothing » inconnue.  Déclaration abandonnée. load-styles.php:4:6454
    Propriété « speak » inconnue.  Déclaration abandonnée. load-styles.php:4:9988
    Propriété « -moz-osx-font-smoothing » inconnue.  Déclaration abandonnée. load-styles.php:4:10052
    Propriété « speak » inconnue.  Déclaration abandonnée. load-styles.php:4:11544
    Propriété « -moz-osx-font-smoothing » inconnue.  Déclaration abandonnée. load-styles.php:4:11608
    Propriété « speak » inconnue.  Déclaration abandonnée. load-styles.php:4:17765
    Propriété « -moz-osx-font-smoothing » inconnue.  Déclaration abandonnée.

    Same for me.

    Plugin Support Marc Lacroix

    (@marcusig)

    Would you be able to add define('SCRIPT_DEBUG', true); to wp-config.php (somewhere at the top of the file), and share the errors again? I can’t reproduce the error, so that would help get a more precise error report.

    Marc.

    Anonymous User 12851872

    (@anonymized-12851872)

    Hi,
    Line 56.
    define('SCRIPT_DEBUG', false); in define('SCRIPT_DEBUG', true);
    or

    define('WP_DEBUG', true );
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    0 error.
    empty debug.log file

    • This reply was modified 4 months, 2 weeks ago by Anonymous User 12851872.
    Plugin Support Marc Lacroix

    (@marcusig)

    Hi @noaneo

    Sorry I’m not sure to get what you’re saying?

    Setting define('SCRIPT_DEBUG', true); should be enough to load the full version of the JavaScript file, which will allow to see the actual line where the issue is. (if the line already exists with false, change it to true).

    Hi, i have the same problem on all my sites (10).

    Console navigateur :

    
    [Exception... "Favicon at "https://api.exactmetrics.com/favicon.ico" failed to load: Not Found."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 227"  data: no] FaviconLoader.jsm:227:22
        onStopRequest resource:///modules/FaviconLoader.jsm:227
    [Exception... "Favicon at "https://s3.envato.com/favicon.ico" failed to load: Forbidden."  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 227"  data: no] FaviconLoader.jsm:227:22
        onStopRequest resource:///modules/FaviconLoader.jsm:227
    [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIContentSniffer.getMIMETypeFromContent]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 286"  data: no] FaviconLoader.jsm:286:24
        onStopRequest resource:///modules/FaviconLoader.jsm:286
        AsyncFunctionNext self-hosted:696
    Error: Can't find profile directory. 2 XULStore.jsm:66:15
    Invalid chrome URI: / 3
    Invalid chrome URI: / 3
    TypeError: window is null 3 WebRequestContent.js:143:7
    Invalid chrome URI: / 3
    Error: Can't find profile directory. 2 XULStore.jsm:66:15
    Invalid chrome URI: /
    Invalid chrome URI: 
    

    Console web :

    
    SyntaxError: unexpected token: numeric literal 2 wpoadmin-3-0-18.min.js:1:2
        format https://gite-sud-ardeche.com/dev/wp-content/plugins/wp-optimize/js/wpoadmin-3-0-18.min.js?ver=3.0.18:1
        jQuery 13
            getParsedText
            buildCache
            commonUpdate
            updateAll
            bindMethods
            dispatch
            handle
            trigger
            trigger
            trigger
            each
            each
            trigger
        update_tables_list https://gite-sud-ardeche.com/dev/wp-content/plugins/wp-optimize/js/wpoadmin-3-0-18.min.js?ver=3.0.18:1
        get_database_tabs https://gite-sud-ardeche.com/dev/wp-content/plugins/wp-optimize/js/wpoadmin-3-0-18.min.js?ver=3.0.18:1
        success https://gite-sud-ardeche.com/dev/wp-content/plugins/wp-optimize/js/send-command-3-0-18.min.js?ver=3.0.18:1
        jQuery 4
            i
            fireWith
            x
            c
    
    • This reply was modified 4 months, 2 weeks ago by verbre.
    • This reply was modified 4 months, 2 weeks ago by verbre.
    • This reply was modified 4 months, 2 weeks ago by verbre.
    • This reply was modified 4 months, 2 weeks ago by Yui. Reason: please use CODE button for proper formatting
    Anonymous User 12851872

    (@anonymized-12851872)

    @marcusig :
    J’ai essayé votre code, 0 message d’erreur.
    define('SCRIPT_DEBUG', true);

    J’ai essayé un autre code pour voir, si j’aurais des messages d’erreur.

    define('WP_DEBUG', true );
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    Mais c’est pareil, pas de message d’erreur..

    Là, je réessaye votre code, juste après la balise <?php
    Toujours pareil, 0 message d’erreur, rien ne s’affiche.

    Que ce soit sous Chrome ou Firefox.
    Avec Firefox, j’ai refait “Inspecter puis Console”
    `SyntaxError: unexpected token: numeric literal 2 wpoadmin.js:1:2

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    A quick sidebar: Folks, please do not add “I’m having the same problem” replies to this topic. Let the author deal with the original poster’s issue(s). If you want to chime in, please start a NEW TOPIC here: https://wordpress.org/support/plugin/wp-optimize/#new-post

    It helps keep things cleaner, as the author can deal with one issue at a time.

    Thanks.

    Note: add-on replies will be removed by the moderators and posters will be asked to post again at the above link.

    No solution ????

    Plugin Support Marc Lacroix

    (@marcusig)

    @marcophile Can you add define('SCRIPT_DEBUG', true); to your wp-config.php, try again, and share the errors again? This should give me a more accurate error.

    Thanks.
    Marc.

    Anonymous User 12851872

    (@anonymized-12851872)

    Hi,
    La version 3.0.17 fonctionnait bien.
    C’est depuis ce changement
    FIX: Don’t override advanced-cache.php if caching is disabled

    J’ai ce fichier advanced-cache.php dans le dossier wp-content, cela pose un problème ?
    Les sites tournent sous PHP 7.3.12 et PHP 7.3.15

    J’ai installé en local sous PHP 7.3.5, avec les mêmes plugins d’un site, sans le fichier advanced-cache.php, cela fonctionne.

    Hi,
    Version 3.0.17 worked well.
    It is since this change
    FIX: Don’t override advanced-cache.php if caching is disabled

    I have this advanced-cache.php file in the wp-content folder, is that a problem?
    The sites run under PHP 7.3.12 and PHP 7.3.15

    I installed locally under PHP 7.3.5, with the same site plugins, without the advanced-cache.php file, it works.

    Je ne trouve pas ce fichier dans le dossier wp-content
    J’utilise Super cache

    Anonymous User 12851872

    (@anonymized-12851872)

    Bonjour @marcophile
    Avez-vous mis ce code
    define('SCRIPT_DEBUG', true);
    dans votre fichier wp-config.php ???

    Si oui, avez-vous des messages d’erreur ??

Viewing 15 replies - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.