WordPress.org

Support

Support » Plugins and Hacks » [Resolved] WP-OpenID stopped working with 10/08 upgrade

[Resolved] WP-OpenID stopped working with 10/08 upgrade

  • I just upgraded my OpenID with the latest version (the version number isn’t explicitly identified, but the download date was 10/4/08).

    Detailed diagnostics show everything OK.

    After logging in with OpenID, there is no way to get to administrative pages. The blog shows me logged in, but every attempt to visit the “/wp-admin/” page is redirected to the login form. The “user” field in the login form is filled in with my openid identifier.

    The redirection URL looks like this:

    http://www.cryptosmith.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.cryptosmith.com%2Fwp-admin%2F

    WHen this used to happen I could type in a specific URL directed to wp-admin and bypass the problem, but not ALL admin URLs redirect to the login page.

    This happens regardless of how I use OpenID: it fails in both delegated and undelegated cases.

    I have SSL enabled for login but not for administration. I tried clearing cookies for the blog but it made no difference.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I talked to Will Norris about this – he suggested I Disable SSL.

    I did so. It works now.

    For now, one must choose between SSL and OpenID. Faustian.

    Rick, good to hear that fixed it. That will definitely make it easier for me to find the root cause. I’ll make sure and get that fixed before the next release.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] WP-OpenID stopped working with 10/08 upgrade’ is closed to new replies.