Support » Plugins » Wp-OpenID — Can’t activate it.

  • Resolved aborisov



    I’ve tried to install Wp-OpenID 2.1.2 but after I’ve activated it it gave me fatal error.

    Parse error: parse error, unexpected ‘=’, expecting ‘)’ in /my_blog/wp-content/plugins/openid/Auth/Yadis/Yadis.php on line 278

    How to fix this? Can somebody answer it?

Viewing 13 replies - 1 through 13 (of 13 total)
  • I got the same problem…

    Please… anybody be helpful? thanks a lot =)

    Looks like WP-Open ID requires PHP 5 now. Take a look at this thread and this post specifically:

    The temporary solution that I have for making this plug-in to work is use an older version. The version I’m using says “$Rev: 21241 $” in Version column in my Plugins section on WordPress.

    I tried the last 4 versions. back to 2.1.1 and still has the same error msg. If wordpress is designed for php4 – why wouldn’t the plugin!
    trying one of the other plugins now.

    the PHP5 dependency was a bug that should be corrected in the latest version (v2.1.7)

    I get this error in WPMU 1.5.1 after I activate the plugin:
    Fatal error: Call to undefined function: wp_get_current_user() in /home/jbtibor/public_html/wp-includes/capabilities.php on line 447

    Everything stops working, I have to delete the plugin from plugins folder on server.



    Using WordPress 2.6.3 and OpenID 3.1.1 on my own server, here’s what I’m getting when I activate the plug-in:

    Warning: require_once(login.php) [function.require-once]: failed to open stream:
    No such file or directory in
    MY_DOMAIN/BLOG_FOLDER/wp-content/plugins/openid/openid.php on line 30
    Fatal error: require_once() [function.require]: Failed opening required 'login.php'
    in MY_DOMAIN/BLOG_FOLDER/wp-content/plugins/openid/openid.php on line 30

    So… anyone have a thought?

    that’s really bizarre that it would fail to open login.php, but not any of the files before it. Are the file permissions on login.php the same as the rest of the plugin files like common.php?



    Without looking at the permissions on those files, I’ve tried to install the version of the plug-in released yesterday, and the result was a complete blog break-down, with an error code rooted in the plug-in folder.

    what do you mean by “complete blog break-down”? And what was the error message?



    “Blog break-down” = activating it may have been successful, but the blog broke before I could get a confirmation of it. Sadly, I didn’t copy the error message. My bad.

    that’s okay, I suspect you had the same error mentioned here. It’s fixed in the 3.1.3 release.



    HUZZAH! Not only can the plug-in be installed successfully, I can even activate it as well!!! I even installed the “xrds-simple” plug-in while about the job! Woo-HOO!

    Thank you for your continuing efforts on everyone’s behalf, oh Leader and Knower of Powerful Code.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Wp-OpenID — Can’t activate it.’ is closed to new replies.