Support » Installing WordPress » wp on macos x

  • hi. i’m a newbie and having troubles installing wp locally on my ibook with mac os 10.3.3, mysql 4.0.2, php 4.3.2.
    i think the first mistake i made was to run the file “install.php” from the command line. later i realized that i should have ran it in a browser.
    after that first mistake, i deleted all the files inside the wp folder and dropped the mysql database i had created for wp.
    then i tried to install all over wp again.
    i have tried to run the “install.php” file with safari, explorer and mozilla. safari simply wont let me open it and explorer never finishes loading the file.
    with mozilla something actually happens but it looks all wrong. the first line in the browser is “wp-config.php file. I need this before we can get started. Need more help?” then there’s a lot of code.. things like:
    require_once('../wp-config.php'); require('upgrade-functions.php'); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; ?>
    is it right to get so much code?
    also it seems like i haven’t completely uninstalled wp. it says:
    “You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.”
    i don’t know what i’m doing wrong…

Viewing 6 replies - 1 through 6 (of 6 total)
  • You shouldn’t get any code like that on the browser when you open install.php. That usually happens when you do not have PHP enabled… are you sure it is enabled? It comes ready-to-use, but first you have to turn it on (and also turn global variables tracking on) on the mac to have it working.
    Also if the database was dropped, there’s nothing left.
    So try this please (you nedd a root shell or do it using sudo before the commands):
    1) open /etc/httpd/httpd.conf with vi and go to the section # Dynamic Shared Object (DSO) Support. Uncomment the line saying #LoadModule php4_module. Go down and uncomment the line saying #AddModule mod_php4.c . Save and exit, PHP will be on next time you start Apache.
    2) open /etc/php.ini with vi, go to the section ; Data Handling ; and chang the line saying register_globals = Off to register_globals = On. Save and exit.
    3) run the mysql command line utility as mysql root user (not the system root user). type show databases; to see if the database you used the first time is really deleted, you shouldn’t see it’s name there. create the database again, and grant the required priviledges to the wordpress user.
    Stop Apache, then start it again. Point the browser to install.php and it should work. If you get any errors during all this post them, please.

    thanks anatman : )
    unfortunately. something is still wrong. i have tried to install twice. and i still get the same page with lots of code when i open the install.php file. i tried clearing the mozilla cache but that didn’t work either.
    maybe i don’t have apache running? i followed this.

    let’s rewind a little then. please follow these steps:
    1 – open Terminal.
    2 – type: sudo apachectl start
    3 – tell me what you see.
    and another test:
    1- open Terminal.
    2 – type: /usr/local/mysql/bin/mysql -u root -p
    3 – if you are asked for a password, type in your mysql root user password. tell me what you see.
    The page you linked to teaches you how to turn on Apache and set up a virtual server, but it doesn’t show you how to turn PHP on. You need PHP to run WP. Are the steps i explained in my first post clear, or do you need a more detailed walk-through?

    hi again =)
    the steps of your first post were very clear. i followed them thru. i assumed that uncommenting meant taking the # off the begginning of the lines. was that correct?
    another variation is that i did not make the changes with vi, but rather, one with emacs and the other with textedit.
    i’ve double-checked and the changes in httpd.conf and php.ini look fine.
    when i put sudo apachectl start on the terminal, it first asks me for my password and then it returns
    /usr/sbin/apachectl start: httpd (pid 522) already running
    i’ve been using the /usr/local/mysql/bin/mysql -u root -p command numerous times these past days. for dropping and creating databases for every new attempt at a wp installation ; )
    this command first asks me for my password and then gives me a mysql> prompt

    Hey, hold it all! Do you have a wp-config.php file in your wordpress/ folder ? You nedd to edit wp-config-sample.php with your data and then rename it wp-config.php, before the installation will run.

    hi anatman : )
    i finally got it to work a few hours ago. the <?php echo ‘this is a test’; ?> test was positive so for a while i was at a loss.
    but somehow it dawned on me that i should point my browser to the files i was creating, as opposed to just telling it to open the files. that did the trick and now i have wp running locally on my ibook. finally =))))

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘wp on macos x’ is closed to new replies.