Support » Fixing WordPress » WP on Mac OS 10.4 (Tiger)

  • After I upgraded to Tiger, WP doesn’t seem to work anymore. When I go to the WP directory, it just shows directory content. And when I click on index.php, it shows me the file content. Any ideas? Do I have to re-install PHP?

Viewing 12 replies - 1 through 12 (of 12 total)
  • And that is an *upgrade* ? 🙂

    How do I find out if PHP has been installed?

    Are you talking about if PHP has been installed on your host server? It wouldn’t have changed just because you upgraded to a different OS, or at least I don’t think it would have…. is this an “apples and oranges” thing?

    I have a commercial hosting plan and I also experiment with stuff on my computer. But after upgrading, PHP on my system seems to have stopped working…

    Everything’s still fine with my hosting that’s for sure!

    Not sure how many Tigerites we have here, maybe try a general Apple for for PHP probs?

    I bet your apache server in tiger doesn’t have php installed or enabled or something like that.

    How do I find out if PHP has been installed?

    at the terminal

    whereis php

    if you get

    /usr/bin/php or something similar…

    it is there.

    The rest is configuring it with apache…

    Apache and PHP are installed by default in Tiger (and previous versions of Mac OS X).

    When you upgrade to Tiger, it overwrites your apache config file (/private/etc/httpd/httpd.conf), and the version that is installed has PHP disabled. Edit that file and uncomment the LoadModule and AddModule directives for mod_php. You can find these easily enough by searchig the file for “php”.

    It is documented that this file may get replaced with OS upgrades, so the best way to make changes to your apache config is to add directives to a file in /private/etc/httpd/users. Files in that directory do not get overwritten, and get loaded by the main apache config file. So if you want PHP to stay active next upgrade, you could add the LoadModule and AddModule directives in there, rather than uncomment them in the main config file.

    Thanks kcm3. It worked like a charm!

    Hi kcm3,

    thanks for your thread which saved my day and taught me about httpd.conf. I tried to follow your advice and setup a httpd.conf file in the etc/httpd/users directory containing only the LoadModule and AddModule directive for php. Then I commented out the corresponding directives in the httpd.conf file itself. Didn’t work. Did I miss something?

    Unfortunately, none of your webserver setup was transferred in the upgrade. you need to reinstall mysql. the best instructions for doing that are at

    Hope this helps.

    I just installed 10.4 within the past few hours and when I when I went to test mine I got the directory list too.

    I checked my /etc/httpd folder and there was a httpd.conf, httpd.conf.applesaved and a httpd.conf.bak all with the same timestamp on them I restored the httpd.conf.bak to httpd.conf and restarted apache. Same thing. I checked it and both php lines were commented. I uncommented them and restarted apache again and still nothing. I didn’t check the .applesaved file to see if it was different from the .bak

    My quick solution, reinstall php from

    I still had the dmg file so I didn’t need to download it. About 30 seconds later after the installer finished everything worked as normal.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘WP on Mac OS 10.4 (Tiger)’ is closed to new replies.