Support » Plugin: rtMedia for WordPress, BuddyPress and bbPress » WP notices after upgrading to WP 5.7

  • After upgrading to WordPress 5.7, I get WP notices:

    WP_Scripts::localize was called incorrectly. The $l10n parameter must be an array. To pass arbitrary data to scripts, use the wp_add_inline_script() function instead. Please see Debugging in WordPress for more information. (This message was added in version 5.7.0.)

    Note: I use Query Monitor plugin to view these.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Pooja N Muchandikar

    (@pooja1210)

    Hi @meijioro,

    We will check the issue and get back to you soon.

    Have a nice day.

    Regards,
    Pooja

    Hi, I have the same problem.

    The stack trace show issues in 2 files:

    18. wp_localize_script() /var/www/html/wp-content/plugins/buddypress-media/app/main/controllers/shortcodes/RTMediaGalleryShortcode.php:97
    
    18. wp_localize_script() /var/www/html/wp-content/plugins/buddypress-media/app/main/RTMedia.php:1277

    The second notice is repeated from line 1277 to 1551

    Regards.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WP notices after upgrading to WP 5.7’ is closed to new replies.