Support » Fixing WordPress » WP Not Creating New Pages

  • I’m trying to create a new page by clicking on Manage>Pages. It appears to be functioning properly from within the admin area; I can click on “Create New Page” and make my title and enter text copy and then click “publish”. The new page appears to have worked within the admin area and I can even edit the entry. However, when I click to “view page”, the page does not exist. There was no directory created and no page. I receive a 404 error.

    I’m sure there’s a simple resolution to this that is going to make me want to slap my forehead and scream “DOH!” Please let me know what that solution is so that I can commence with the slapping!

    Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • did you publish the page?

    Yes. I’m sorry if that part of my post was not stated clearly.

    Still need help on this please….

    There was no directory created and no page

    Nor will there be. That’s all in your database.

    Without a link, this is just a guess, but I’m going to guess that your Permalinks aren’t working.

    If you visit Options -> Permalinks and set them to Default, do links work? If so, check the Permalinks page for troubleshooting tips.

    Okay, I had permalinks set to date and name based, which I would rather, but I changed them back to default. The response was to “update your .htacess now.” Could you refresh my memory as to how to do that?

    Thanks.

    I just finished changing to default. It worked, but I’d like to change it to “date and name” which I imagine means I need to change my htaccess. Again, could you please briefly explain that?

    Keilya

    (@fantasycrusader)

    Maybe if you provided a link to your blog, we could better help you with your problems. Handy was simply guessing your problem may lie with the permalinks, but they may not be (and you may be headed down the wrong direction).

    Please provide a link for the rest to better assist you?

    Thanks fantasy,

    I’m actually working on two blogs on the same site; each having their own directory and most everything functions with this exception.

    The htaccess helped on one, but not the other.

    The two blogs are at
    http://the-secret-book.com/the-secret-cons/ this one appears to be functioning properly.

    The other is at
    http://the-secret-book.com/the-secret-pros/ this one does not appear to be functioning properly yet.

    MatthewEbel

    (@matthewebel)

    I’m experiencing the same issue at matthewebel.com, but my .htaccess file is set up correctly and permissions are set to allow WP to rewrite.

    MatthewEbel

    (@matthewebel)

    I upgraded to 2.3.1 and the problem still isn’t resolved.

    Same issue here in 2.3.3. WordPress is dumping the page rather than saving it. When I use “Save and continue editing” I get the response “You attempted to edit a page that doesn’t exist. Perhaps it was deleted?” When I use the “Save” button it responds with a new “Write New Post” page and my original work is gone. When I use “Publish” the new page does not get posted and a check of the database using phpMyAdmin on my host shows that the page is not added to the database. Trying to post a page using Windows Live Writer causes an Error 500 response from the server (although posting a regular article with the same software does NOT respond with that error). Trying to post in Safari 3 for Windows produces the message “Safari can’t open the page “http://www.life3.org/wp-admin/page.php”. The error was: “unknown error” ((null):10053) Please choose Report Bugs to Apple from the Help menu, note the error number, and describe what you did before you saw this message.”

    There were no changes made that I can see to any other part of the site except for the update from WP 2.3.2 to WP 2.3.3. It appears a bug has been introduced in 2.3.3 that needs attention.

    Hi Everyone..

    Im getting exactly the same thing, trying to create a page, and then its saying am I sure I want to edit it, and when I click Yes, I get that message saying im tring to edit a page that doesnt etc..

    I was wondering if there is a fix for this yet? as I can’t seem to find anything..

    Many Thanks

    Martin

    WP 2.3.3
    Running locally with Xammp at the moment..

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WP Not Creating New Pages’ is closed to new replies.