Support » Networking WordPress » WP Network: Subdomain 'Internal Server Error'

  • Resolved ET.Baldosser


    Hello, I am attempting to set up a wordpress network. I’ve followed Andrea’s helpful tutorial along with Mercadder’s instructions for Bluehost. Everything seemed to go smoothly:
    – Created a subdomain and record in the DNS Zone Editor. It worked and the subdomain, exists
    -Allowed multisite in wp-config and installed network. I have the Super Admin panel.
    -Added the domain, under Super Admin/sites.

    So everything seems good except that when clicking ‘backend’, I get this:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request…
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache Server at Port 80

    I feel like I’m so close but I can’t get a theme to show up at the domain. Can someone please suggest where I might look to trouble shoot this? Thank You!!!

Viewing 15 replies - 1 through 15 (of 18 total)
  • Make a subdomain record with a value of *. point it at the root folder.

    If not,

    It worked and the subdomain, exists

    If you made this, and it’s got a real folder set up on the server, that is why it’s not working. It *has to* point to where WordPress installed.

    If WP is not in the default domain in your web account, that;s another reason why it won;t work for you on that host.

    Hi Andrea, I was hoping I might hear from you! First off, thanks so much for your tutorial on setting up a network, it came in very handy. Please bare with me as I try to wrap my head around this…

    I made a subdomain record named, instead of * I know that Mercadder was able to create a wildcard subdomain but when I attempted to do so it didn’t work and after talking with BlueHost tech support, I was told that they do not accept wildcard subdomains. (I don’t need a bunch of subdomains, just this one, so I thought that this would be ok).

    The document root for my subdomain,, is (home)/public_html/metamakers

    Does that sound correct? From what I can tell (again, apologies for my limited knowledge), Worpress is installed in public_html and there is a folder called metamakers in public_html as well.

    I think you’re on the right track- this must be a matter of not having my directories set up right. Unfortunately I’m still learning. So thanks for your help!
    Also, How can I tell if WP is the default domain in my web account?

    The document root for my subdomain,, is (home)/public_html/metamakers

    Does that sound correct? From what I can tell (again, apologies for my limited knowledge), Worpress is installed in public_html and there is a folder called metamakers in public_html as well.

    And that’s the problem – if you’re using manual subdomains, the server sets up a folder for the files. Multisite will not look at this folder. you need to change the subdomain record so it points to just public_html.

    Worpress is installed in public_html ….
    Also, How can I tell if WP is the default domain in my web account?

    If it’s in public_html. 😉

    Aha! Well that was deceptively simple.

    Thank you so very much Andrea. I really admire your advocacy and work to give everyone the ability to WP. It’s a great gift that makes the WP community very special.

    Well simple but not foolproof…

    Now that the subdomain record points to just public_html, the website does work and I can create new posts. However, it doesn’t seem to have full functionality: in particular, images are broken links- I can upload an image to a post but it doesn’t load.

    Additionally, Theme Options are not showing up under Appearance in the back-end, nor do widgets work.

    It seems like this is a related problem with the structure of my directories, but I don’t have the understanding to know what needs to be changed.

    The theme stuff is a theme issue if you;re not logged in as the super admin.

    Hmm… I am definitely logged in as the super admin. The themes and images work fine for my domain,, but do not work correctly for my subdomain, This is why I think it must be an issue with my directories.

    In other words, the problem seems to be that inserting images into a new post for the subdomain does not work. I can choose them from a file on my computer but they never load into the post. I can publish the post to the subdomain but again, the images never load.

    Currently, all themes are in public_html/wp-content/themes
    Does a theme for the subdomain need to be placed somewhere else?
    Does my images folder need to be somewhere else?

    No, your theme forlder is fine. the theme has nothing to do with the image uploading.

    Did you make the blogs.dir folder on the server as stated in the instructions when you set up multisite? this is where the sub-sites store their image uploads.

    Yup, the folder blogs.dir is in wp-content. Going deeper within, images are indeed loading into /public_html/wp-content/blogs.dir/2/files/2010/11

    What’s in your .htaccess?

    Here is the contents of .htaccess:

    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    Okay, that’s good…

    Broken Image:

    Working Image:

    Looking at your other site…

    Which makes me think that mod-rewrite isn’t working right? Both those URLs should work.

    Very interesting. I’ve changed my permalinks structure to default, just in case.
    Could this be a problem with .htacces’ syntax? For instance, is it correct to have the “[OR]”?:

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d

    I’ve double-checked everything else and it looks good.

    Thanks for your help, ipstenu, this is a bit over my head.

    No, OR is right.

    Can you ask your host to double check that mod_rewrite is on?

    I’ve confirmed with BlueHost that mod_rewrite is on.

    Additionally, I’ve deactivated plugins and checked the upload path (wp-content/blogs.dir/2/files)
    Like the blogger in this thread, “Even the thumbnails don’t show up in the media tab, but the weird thing is that the ‘Edit Image’ function still works just fine.”
    I’ve been switching among Firefox, Chrome, and Safari to no avail.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘WP Network: Subdomain 'Internal Server Error'’ is closed to new replies.