Support » Networking WordPress » WP multisite dynamic robots.txt shows “sitemap”

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have no sitemap.xml and no news-sitemap.xml in the subdomain.
    Josef

    The top of robots.txt
    Sitemap: h-t-t-p-s://my_subdomain/sitemap.xml
    Sitemap: h-t-t-p-s://my_subdomain/news-sitemap.xml
    is the same in all secure domains (main and subs).

    What I tried:
    I disabled the described function, so that WP produces its original robots.txt ,
    and I disabled all plugins.
    But nothing changed.
    Is there something to modify in the orininal
    “apply_filters( ‘robots_txt’, $output, $public )” ?

    Thx in advance for your help.

    After all, the Jetpack plugin was the reason.
    In …../wp-content/plugins/jetpack/modules/sitemaps/sitemaps.php
    I disabled the following lines:
    `// Add sitemap to robots.txt.
    add_action(
    ‘do_robotstxt’,
    array( $this, ‘callback_action_do_robotstxt’ ),
    20
    );`

    Regards,
    Josef

    This is a hint, not a question.

    Best method (phrases translated from German WP):

    wp-admin
    Jetpack in Dashboard
    Configuration
    Traffic
    Sitemaps
    Disable “Generate XML sitemaps”

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP multisite dynamic robots.txt shows “sitemap”’ is closed to new replies.