WordPress.org

Forums

W3 Total Cache
wp-mu or large site may have problem with database cache funtion (5 posts)

  1. Nadiamode
    Member
    Posted 3 years ago #

    if your site have new user register every 1-3 minute and you have enabled database cache then check your wp_users table in database regularly because plugin run query when user register again and again (run from cache in your ram that store for 180 second) so you'll have many duplicate user in database

    tick " Don't cache queries for logged in users" doesn't work because user not logged-in when they register

    fixed: put "users" in "Ignored query stems:" so plugin wont cache query when visitor register

    --------------------------
    if your site have many users, you can run this query to check duplicate user

    SELECT user_login, user_email, count(*)
    FROM wp_users
    GROUP BY user_login, user_email
    HAVING count(*) > 1

    --------------------------

    sometime database cache have problem with wp_comments too but only happen with very large site that have many comments

    all regular sites not affected

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    That will slow your site down QUITE a bit. Once a user registers, they should be logged in and database caching should be disabled (that's the default setting).

  3. Nadiamode
    Member
    Posted 3 years ago #

    if it default setting why i get many duplicate user before i put "users" in Ignored query stems: ?

    or i have to tick "Don't cache queries for logged in users" too ?

    my site handle with many logged-in users because some content hidden to visitor but show to logged-in users only so i dont want to overload mysql query then i try un-check "Don't cache queries for logged in users" (my site also run many query)

    is it okay for my case ? if i un-check "Don't cache queries for logged in users" and use "Ignored query stems:" to prevent duplicate user problem while optimize db query for logged-in users

  4. Nadiamode
    Member
    Posted 3 years ago #

    hi, after i run a plugin with default settings for 2-3 days

    i found that there re still DUPLICATE user in table WP_USERS in database

    i have tick "Don't cache queries for logged in users" in "Database Cache" already

    now i have to put "users" in "Ignored query stems:" to prevent duplicate row problem

    anybody use db cache and have problem same me? check your users table

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Can you please submit a bug submission form from the support tab of the plugIn if you haven't already?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic