Support » Plugins » WP-Members: Itunes responds with login error to every user

  • Hi,

    to be honest i am not a pro in WP and plugins, but i got the Members-Plugin working on the last WP-Version before 3.3. It worked for my premium members and granted them access through the podpress premium feed. Since i updated to WP 3.3 the premium-users are still able to login directly on the site and use the premium content, but iTunes keeps telling them that they have the wrong password for the feed. I don´t know if this is a Problem with Members or with Podpress, but i am pretty desperate to get this fixed.

    Has anyone else experienced Problems with that?


Viewing 15 replies - 1 through 15 (of 32 total)
  • meetwp


    I’m actually having the same issues but am on WP 3.2.1.
    It is my first time to try the premium feed in iTunes but keep getting the username and password rejected even if when used on the website they work fine, enabling podpress premium content to be accessed without a problem.

    Have you been able to solve your issues?



    Seems a similar issue was reported on Powerpress too.

    What got my attention is

    If you get it down to the basic common denominator, use the default user capability that PowerPress adds and make sure that user has that capability, then it should work. Chances are you are either using a different capability for the premium feed, or the other plugin has it’s own capability (roles and capabilities) that you need to associate both the premium feed and the user to.

    As I did not have the Premium Content role activated by Podpress, but had to add it manually as premium_content. I wonder if I spelled it out badly and it is now not working in the feed as the feed code is connected to another capability, maybe spelled premium_contents?

    Let us wait for Ntm to give us his suggestions.



    I have been testing a lot on this lately. I tried to associate a new Role. I set up the capability “premium_content” for this users. I restricted Podpress to use only posts given the “premium” tag. I even changed the complete Feed including its Adress. As a last resort i have even made a complete new Install of WordPress with all my Plugins and Themes and tried to set up the Members-Plugin first, so i doesn´t get distracted by other Plugins. Neither of these Methods work for me. At this moment i am at my wits end. I come to think that the issue might be in iTunes it self, because everything works fine on my site and the only thing not working is the password-restriction in iTunes. The feed itself is obviously working since i can subscribe to it in iTunes and it requests a password.



    I had similar issues just protecting podpress media files.
    I honestly think Podpress needs a bit of work to take care of all these issues. Maybe also updating the plugin guides.

    I don’t think it is an iTunes related issue.
    If you try subscribing to the protected feed with another rss client like NetNewsWire you should get the same issue.
    So I think it is related to the podpress and wordpress integration.



    One last test that could be done might be to do a new installation with just WordPress and podpress. Then created a feed. Register a user and see if this user can access the premium podcast in iTunes.

    I still have a feeling that the issues are caused by podpress as the premium_content capability should have been loaded automatically in my installation, but it podpress didn’t. So I had to use Members to create the premium_content manually.
    This lack of integration might also affect the premium_feed which is not connected to WordPress user data.

    Have you had any luck fixing this issue?

    Nope, no success so far. But to be honest, i did not put much effort in it, since i testet everything up to a complete new WP-Installation. This morning i updated Podpress. It was claimed to be 100% compatible with WP but that leaves our problem completely untouched. Everything is still working except the premium feed.

    I’ve contacted seek3r, the original creator.
    Offering to get a group of people like you and me to make some donations and maybe get enough to get podpress developed on a more stable basis and help the wordpress community.
    Unfortunately no answer yet, maybe my email went in the spam folder.

    You are correct this problem is not fixed in v8.8.10.13. But it is not forgotten.

    You may try the current Development Version (v8.8.10.14 beta 3). I have looked into the whole premium login stuff and could find and fix some issues.

    This beta version includes a bug fix:
    If the Premium Content feature is activated and you save the general settings of podPress then podPress checks whether the premium_subscriber role exists and creates it if necessary.


    Dear ntm,
    thank you for your help and continuous support.
    I think we all understand how busy you some of us might be willing to gather enough donations to get pod press developed and improved even more than it is now.
    How do the donations work, would you be getting a percentage?

    Thank you

    I would also be donating a bit. Your work is really appreciated. Without guys like you, ntm, we would not be able do what we like. So, a donation would be more than gladly given. If there is anything else, like testing something or giving you system information, just ask.

    You are f*****g amazing. I just installed the dev-version and everything works from the get go. This is completely awesome. Thank you very, very much!!! Please let us know how to throw a dime in your hat.

    Reliefed Greetings,

    If I can suggest waiting to make a donation and us finding a way to get more people onboard to keep this marvelous piece of software developed and directly donating to the people now working on it.

    By the way, is iTunes log in working fine?

    Yes it is. Absolutely smoothly. I deactivated Podpress, deleted the premium_subscriber user role that i set up myself, deleted podpress and installed the beta 3. Saved properties of the premium feed. Done. Everything as it should be. Down to the last post.
    Just amazing to see after a month of trying and failing. Keep me posted about your plans. I will talk to some people around here who are using podpress as well.

    It is nice of you that you would like to make donation. But I have no donation button nor account. For instance because I’m currently (and for the next 3 months) in a situation in which I have simply not much time for podPress and a donation would not help.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘WP-Members: Itunes responds with login error to every user’ is closed to new replies.