Support » Plugin: WP-Matomo (WP-Piwik) » wp-matomo proxy not working

  • navnet

    (@navnet)


    Hello everyone, can anyone help me?

    WP-Matomo 1.0.22
    Mode: http
    
    Test 1/3: global.getPiwikVersion
    
    string(6) "3.12.0"
    
    array(2) {
      [0]=>
      string(201) "HTTP/2 200 
    date: Tue, 12 Nov 2019 16:12:07 GMT
    server: Apache
    x-powered-by: PHP/7.1.33
    x-matomo-request-id: 835bd
    cache-control: must-revalidate
    content-type: application/json; charset=utf-8
    
    "
      [1]=>
      string(139) "https://golink.ovh/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3D1&token_auth=..."
    }
    
    Test 2/3: SitesManager.getSitesWithAtLeastViewAccess
    
    array(1) {
      [0]=>
      array(20) {
        ["idsite"]=>
        string(1) "1"
        ["name"]=>
        string(3) "ALL"
        ["main_url"]=>
        string(21) "http://chavemestra.pt"
        ["ts_created"]=>
        string(19) "2019-11-03 00:00:00"
        ["ecommerce"]=>
        string(1) "0"
        ["sitesearch"]=>
        string(1) "1"
        ["sitesearch_keyword_parameters"]=>
        string(0) ""
        ["sitesearch_category_parameters"]=>
        string(0) ""
        ["timezone"]=>
        string(13) "Europe/Lisbon"
        ["currency"]=>
        string(3) "EUR"
        ["exclude_unknown_urls"]=>
        string(1) "0"
        ["excluded_ips"]=>
        string(0) ""
        ["excluded_parameters"]=>
        string(0) ""
        ["excluded_user_agents"]=>
        string(0) ""
        ["group"]=>
        string(0) ""
        ["type"]=>
        string(7) "website"
        ["keep_url_fragment"]=>
        string(1) "0"
        ["creator_login"]=>
        string(9) "anonymous"
        ["timezone_name"]=>
        string(17) "Portugal - Lisbon"
        ["currency_name"]=>
        string(4) "Euro"
      }
    }
    
    array(2) {
      [0]=>
      string(201) "HTTP/2 200 
    date: Tue, 12 Nov 2019 16:12:07 GMT
    server: Apache
    x-powered-by: PHP/7.1.33
    x-matomo-request-id: f2644
    cache-control: must-revalidate
    content-type: application/json; charset=utf-8
    
    "
      [1]=>
      string(162) "https://golink.ovh/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3D1&token_auth=..."
    }
    
    Test 3/3: SitesManager.getSitesIdFromSiteUrl
    
    array(1) {
      [0]=>
      array(1) {
        ["idsite"]=>
        string(1) "1"
      }
    }
    
    array(2) {
      [0]=>
      string(201) "HTTP/2 200 
    date: Tue, 12 Nov 2019 16:12:08 GMT
    server: Apache
    x-powered-by: PHP/7.1.33
    x-matomo-request-id: 02f1d
    cache-control: must-revalidate
    content-type: application/json; charset=utf-8
    
    "
      [1]=>
      string(198) "https://golink.ovh/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DSitesManager.getSitesIdFromSiteUrl%26idSite%3D1%26url%3Dhttps%3A%2F%2Fjl-desentupimentos.pt&token_auth=..."
    }
    
    array(2) {
      ["global_settings"]=>
      array(67) {
        ["revision"]=>
        string(10) "2019072901"
        ["last_settings_update"]=>
        string(10) "1573575066"
        ["piwik_mode"]=>
        string(4) "http"
        ["piwik_url"]=>
        string(25) "https://golink.ovh/piwik/"
        ["piwik_path"]=>
        string(0) ""
        ["piwik_user"]=>
        string(0) ""
        ["matomo_user"]=>
        string(0) ""
        ["piwik_token"]=>
        string(3) "set"
        ["auto_site_config"]=>
        string(1) "0"
        ["default_date"]=>
        string(9) "yesterday"
        ["stats_seo"]=>
        string(1) "0"
        ["stats_ecommerce"]=>
        string(1) "0"
        ["dashboard_widget"]=>
        string(8) "disabled"
        ["dashboard_ecommerce"]=>
        string(1) "0"
        ["dashboard_chart"]=>
        string(1) "0"
        ["dashboard_seo"]=>
        string(1) "0"
        ["toolbar"]=>
        string(1) "0"
        ["capability_read_stats"]=>
        array(7) {
          ["administrator"]=>
          string(1) "1"
          ["editor"]=>
          string(1) "0"
          ["author"]=>
          string(1) "0"
          ["contributor"]=>
          string(1) "0"
          ["subscriber"]=>
          string(1) "0"
          ["wpseo_manager"]=>
          string(1) "0"
          ["wpseo_editor"]=>
          string(1) "0"
        }
        ["perpost_stats"]=>
        string(1) "0"
        ["plugin_display_name"]=>
        string(8) "WP-Piwik"
        ["piwik_shortcut"]=>
        string(1) "0"
        ["shortcodes"]=>
        string(1) "0"
        ["track_mode"]=>
        string(8) "manually"
        ["track_codeposition"]=>
        string(6) "footer"
        ["track_noscript"]=>
        string(1) "0"
        ["track_nojavascript"]=>
        string(1) "0"
        ["proxy_url"]=>
        string(19) "//golink.ovh/piwik/"
        ["track_content"]=>
        string(8) "disabled"
        ["track_search"]=>
        string(1) "0"
        ["track_404"]=>
        string(1) "0"
        ["add_post_annotations"]=>
        array(0) {
        }
        ["add_customvars_box"]=>
        string(1) "0"
        ["add_download_extensions"]=>
        string(0) ""
        ["set_download_extensions"]=>
        string(0) ""
        ["set_link_classes"]=>
        string(0) ""
        ["set_download_classes"]=>
        string(0) ""
        ["disable_cookies"]=>
        string(1) "0"
        ["limit_cookies"]=>
        string(1) "0"
        ["limit_cookies_visitor"]=>
        string(8) "34186669"
        ["limit_cookies_session"]=>
        string(4) "1800"
        ["limit_cookies_referral"]=>
        string(8) "15778463"
        ["track_admin"]=>
        string(1) "0"
        ["capability_stealth"]=>
        array(0) {
        }
        ["track_across"]=>
        string(1) "0"
        ["track_across_alias"]=>
        string(1) "0"
        ["track_crossdomain_linking"]=>
        string(1) "0"
        ["track_feed"]=>
        string(1) "0"
        ["track_feed_addcampaign"]=>
        string(1) "0"
        ["track_feed_campaign"]=>
        string(4) "feed"
        ["track_heartbeat"]=>
        string(1) "0"
        ["track_user_id"]=>
        string(8) "disabled"
        ["cache"]=>
        string(1) "1"
        ["http_connection"]=>
        string(4) "curl"
        ["http_method"]=>
        string(4) "post"
        ["disable_timelimit"]=>
        string(1) "0"
        ["filter_limit"]=>
        string(0) ""
        ["connection_timeout"]=>
        string(1) "5"
        ["disable_ssl_verify"]=>
        string(1) "0"
        ["disable_ssl_verify_host"]=>
        string(1) "0"
        ["piwik_useragent"]=>
        string(3) "php"
        ["piwik_useragent_string"]=>
        string(8) "WP-Piwik"
        ["dnsprefetch"]=>
        string(1) "0"
        ["track_datacfasync"]=>
        string(1) "0"
        ["track_cdnurl"]=>
        string(0) ""
        ["track_cdnurlssl"]=>
        string(0) ""
        ["force_protocol"]=>
        string(8) "disabled"
        ["update_notice"]=>
        string(7) "enabled"
      }
      ["settings"]=>
      array(6) {
        ["name"]=>
        string(0) ""
        ["site_id"]=>
        string(1) "1"
        ["noscript_code"]=>
        string(150) "<noscript><p><img src="//jl-desentupimentos.pt/wp-content/plugins/wp-piwik/proxy/matomo.php?idsite=1&rec=1" style="border:0;" alt="" /></p></noscript>"
        ["tracking_code"]=>
        string(669) "<!-- Matomo -->
    <script type="text/javascript">
      var _paq = window._paq || [];
      /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
      _paq.push(['trackPageView']);
      _paq.push(['enableLinkTracking']);
      (function() {
        var u="//jl-desentupimentos.pt/wp-content/plugins/wp-piwik/proxy/"
        _paq.push(['setTrackerUrl', u+'matomo.php']);
        _paq.push(['setSiteId', '1']);
        var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
        g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'matomo.php'; s.parentNode.insertBefore(g,s);
      })();
    </script>
    <!-- End Matomo Code -->
    "
        ["last_tracking_code_update"]=>
        string(1) "0"
        ["dashboard_revision"]=>
        string(1) "0"
      }
    }
    

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author braekling

    (@braekling)

    Please have a look at this thread:
    https://wordpress.org/support/topic/built-in-tracker-proxy/

    There you find a link to a new version which should solve the issue. Sadly, I didn’t get a feedback on this yet. If you can have a look and tell me if it works, I can provide a new release.

    Not OP, but new version worked for me in fixing proxy tracking. You should definitely push it out. Thank you.

    Hi, same problem here… I’ve got 3 dedicated server, 1 is hosting matomo, 3 are hosting websites. 2 old ones are working great proxy tracking is working. I move websites from 1st old (hosting matomo) to the new server. Since proxy tracking (even with 1.0.23) is not working, no JS/PHP errors, well connected, just no tracks. If i set default tracking code it’s working but display my matomo url instance. I just want proxy script working…

    I have tried the support script / clean / etc… I’ve tried clean all caches.

    Just 1 difference for me : php cli 7.3 on new server, php cli 7.0 on old servers.

    Any news ?

    found something odd in matomo.php line 107

        'header'     => sprintf("Accept-Language: %s\r\n", str_replace(array("\n", "\t", "\r"), "", arrayValue($_SERVER, 'HTTP_ACCEPT_LANGUAGE', ''))),
    

    this is generating bad header with spaces at the end, need/better to use

    trim( sprintf("Accept-Language: %s\r\n", str_replace(array("\n", "\t", "\r"), "", arrayValue($_SERVER, 'HTTP_ACCEPT_LANGUAGE', '')) )

    I don’t know why, but it resolved my problem

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wp-matomo proxy not working’ is closed to new replies.