Support » Plugin: WP Maintenance Mode » WP Maintence mode with Hide My WP

  • Hi! It seems that WP Maintenance mode is not working with Hide My WP. The maintenance page shows error 503 and admin also can’t log out if Hide my WP is active. I tried with the default settings of Lite mode in Hide My WP. I disabled WP Maintenance Mode for a moment and there wasn’t any 503 errors and admin could log out. WordPress version is 5.5.3, php 7.4 and theme Twenty Twenty.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author George J

    (@georgejipa)

    Hello @sankoweb1,

    1. If you see a 503 error instead of the maintenance mode page (which is a custom 503 error page), your web server is not configured correctly. You should tell your hosting provider that you want to use the 503 error page from WordPress.

    2. I have never used Hide My WP, but I suppose you changed the login/logout/wp-admin URLs. If yes, you should add each changed slug to the Exclude settings.

    Example: If the new login URL is https://domain.com/custom-login/, you should add custom-login to the Exclude settings.


    George

    Hi @georgejipa ,

    Thank you for the reply.

    1. I can see the custom maintenance page when Hide My WP is disabled. So I guess the server is alright.

    2. Yes I changed them. I added them to exclusion list, but it didn’t make any difference. Although, a couple of times I ended up having an empty WP maintenance mode settings page saying “security check” in the upper corner. Maybe I should ask Hide My WP about this?

    Plugin Author George J

    (@georgejipa)

    Hello @sankoweb1,

    You see the “Security check” message only if the nonces are not valid. So, I suppose that “Hide My WP” is changing (somehow) the _wpnonce fields.

    Anyway, I will probably test “Hide My WP” somewhere in the future (no ETA, though). For now, I recommend disabling it when you use the maintenance mode because it is making too many breaking changes.


    George

    • This reply was modified 2 months, 2 weeks ago by George J.
    • This reply was modified 2 months, 2 weeks ago by George J.
    • This reply was modified 2 months, 2 weeks ago by George J.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.