Support » Plugin: WP Mail SMTP by WPForms » WP Mail SMTP with Multisite

  • Resolved spollock

    (@spollock)


    Just brought up a multi-site instance of WP.

    WP Mail works fine for the first (default site) that comes with the installation. When I add sites and configure the credentials etc. it fails.

    Credentials are exactly the same as the default site.

    In this case, all sites will use the same SMTP relay.

    Couple of questions:
    1) Any idea why it works on the default site and none of the others even though everything is identical?
    2) Is there a way to just make the settings global for all sites?

    Many Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @spollock

    I apologize but currently, we do not fully support WP Mail SMTP on WordPress Multisite. This is definitely on our radar though.

    Currently can activate the plugin network-wide and set up SMTP settings by defining constants in your wp-config.php. If you define the details in wp-config, then the same settings will be applied across subsites. Please open the file wp-content/plugins/wp-mail-smtp/wp_mail_smtp.php – at the top of the file there will be the list of all constants that you can use, with descriptions.

    I hope this helps!

    DesktopMasters

    (@desktopmasters)

    Just an FYI.. The above does not ring true.
    I configured the constants in the wp-config.php file.
    The main site can send EMail.
    The subsite cannot. The config page reads and shows the contents however when I send the test EMail it does not use them…

    https://i.imgur.com/6PDX4jz.png
    https://i.imgur.com/NmSwmiy.png

    It would mean a great deal to me if you would list that you do not support multisite on your main description page.

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @desktopmasters,

    I apologize for the trouble. Settings constants on wp-config.php for multisites should work absolutely fine. When you get a chance, could you please let me know what is the host and port you’re using? The error debug suggests you’re using localhost as host and 25 port number. If you’re not adding these settings in your wp-config.php, it might be a plugin conflict or your server is utilizing these SMTP settings irrespective of settings in WP Mail SMTP.

    Thanks!

    DesktopMasters

    (@desktopmasters)

    587 the settings I put in the wp-config.php file are all right there in the first picture. The settings page reflects the right information. The test page does not use them.

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @desktopmasters,

    Thanks for the information. So, it seems you’re setting up constants correctly but the SMTP settings to send emails are taken from another plugin, theme or enforced by your server. You will have the same SMTP details in the log even when you enter the SMTP settings in the settings page instead of defining constants in wp-config.php. If you’d like to test for the conflict, we have a tutorial.

    I hope this helps!

    These settings worked great in the wp-config.php. This is a really great feature for Multisites. Thanks!

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @jcow – Great to hear that helped to setup SMTP in your multisite.

    @desktopmasters – I hope you sorted out the issue too by resolving the SMTP conflict you’re having. If not, please feel free to continue the conversation.

    Have a good one! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WP Mail SMTP with Multisite’ is closed to new replies.