Support » Plugin: WP Mail SMTP by WPForms » WP Mail SMTP set up with gmail

  • Resolved tonyatreewp

    (@tonyatreewp)


    I’ve managed to set-up WP Mail SMTP with gmail, but found the instructions at
    https://wpmailsmtp.com/docs/how-to-set-up-the-gmail-mailer-in-wp-mail-smtp/ not at all helpful. I suspect the google interface has changed substantially since these instructions were written. Is it possible for you to update the instructions?

    While I’ve got it working, I’m not confident that I’ve done it right. I had to setup my email as a test user before it would “Allow plugin to send emails using your Google account”, otherwise it was saying I didn’t have access.

    I’d appreciate knowing whether it sounds to you like I’ve set it up correctly.
    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Gregor Capuder

    (@capuderg)

    Hi @tonyatreewp,

    thank you for reporting this.

    We have an update for the Google mailer guide in the works, so the guide should be updated in the upcoming weeks.

    Your Google API OAuth app should not be in test mode, because this will make your connection break after 7 days, and you would have to re-connect it in our plugin. To fix this, could you please check if the google API project is in the “Production” mode by going to the Google API console, opening the project for our plugin integration, then go to “OAuth Consent Screen” and check the “Publishing status”. More info can be found in this screenshot. It should say “In production”.

    Let me know how it goes.

    Have a nice day!

    Thread Starter tonyatreewp

    (@tonyatreewp)

    Hi Gregor

    Thanks for taking the time to reply and for giving me some help. I really appreciate it.

    I went to where you suggested in Google API Console. I had to click on Publish but it now says it’s ‘in production’. So hopefully that will be okay now.

    I’ll keep an eye out for the updated guide. I think it would be worth me checking it all over: I didn’t find it easy to work through knowing very little about google cloud platform.

    Thanks again for your help.

    Best wishes
    Tonya

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi Tonya,

    we are working on the doc update and hope to release/update it soon.

    For now, please also go to the WP Mail SMTP plugin settings, removed the connection, and re-connect.

    This action is needed in order to connect with the new app config (since you changed it to “Production”). Your current connection is still using the Test mode configuration.

    Have a nice day!

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi Tonya,

    I just wanted to let you know that we updated the Gmail mailer guide, more specifically, the 2nd and 3rd section of the guide.

    Please let me know if there are still any items in the guide that are not understandable.

    Have a nice day!

    bgWriter11

    (@bgwriter11)

    Good Day,

    I started trying to configure WP Mail SMTP May 9. I returned May 18 to try and complete the setup and find that I can’t change the authorized redirect URI in configure email settings. I learned that the OAuth has to be moved to production by finding this post. The instructions are still out of sync with the process flow on Google.
    The Authorized Redirect URI that is defaulting in the plugin setup –
    https://connect.wpmailsmtp.com/google/ – is not accepted in Google API credentials because it has a path.
    I will try to reset in production mode but this is a very inauspicious introduction.

    • This reply was modified 1 month ago by bgWriter11.
    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @bgwriter11,

    The Google mailer setup documentation has been updated. Please follow all the steps in the documentation to set up.

    Please make sure you’re adding https://connect.wpmailsmtp.com/google/ in ‘Authorized Redirect URI’ section and not on ‘Authorized JavaScript origins’ which do not accept this format.

    I hope this helps!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.