Support » Plugin: WP Mail SMTP by WPForms » WP Mail SMTP Not sending any Emails

  • Resolved hobgoblins

    (@hobgoblins)


    Hello.
    I have a strange issue.

    WP Mail SMTP is not sending any emails. I tried the Email Test and it say’s
    Test HTML email was sent successfully! Please check your inbox to make sure it is delivered.

    Nothing shows on any email I try it on. Not even in the spam folder.
    I have Formidable Forums for Contact and it says it sent it out. But again nothing.
    Woocommerce orders don’t even show anymore either.

    This has been a problem for over a week now. It worked perfectly fine and all the sudden stopped working. I updated the WP Mail SMTP

    Nothing was updated to affect it at all. It just randomly stopped working on v1.4.2
    I updated to 1.5.0 and no success.
    The last update was 1.5.1 and seen the “others not receiving their emails” fix.
    So I updated to that and I tried the Email Test and it worked only once and stopped again.

    I then decided to update WordPress to the latest version and all the plugins I have and made no difference. It says it sent an email and never does.

    Last true email it sent out was on Fri, Jul 5, 6:05 AM
    Almost forgot to mention, I’m using Gmail

    • This topic was modified 6 months, 1 week ago by hobgoblins.
    • This topic was modified 6 months, 1 week ago by hobgoblins.
Viewing 10 replies - 1 through 10 (of 10 total)
  • I just want to confirm that 2FAS — Two Factor Authentication is conflicting with WP Mail SMTP. That seems to be my issue unfortunately.

    It’s still acting up unfortunately. It’s not working with Formidable or Woo Commerce.

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @hobgoblins,

    When you get a chance, could you please confirm if you could receive the test email after fixing the issue with Two Factor Authentication? For the Formidable forms and WooCommerce, please check the ‘From Email’ field in their settings. The ‘From Email’ must be set to the same email address as the email used to set up the SMTP plugin.

    Thanks!

    As I mentioned it’s not 2FAS — Two Factor Authentication.

    I’ll be more clear on the issue.
    It last truly worked Fri, Jul 5, 6:05 AM and sent out a WooCommerce order. Then stopped after that. Nothing was updated or tweaked on the server. WP Mail SMTP v1.4.2 just gave up on sending emails.
    So I updated to WordPress 5.2.2 and updated WP Mail SMTP 1.5.0 with no success then WP Mail SMTP 1.5.1 came out and still nothing changed.

    At this point, I started to disable all plugins and try the Email Test button. It worked thinking it was conflicting, but how could it when nothing was changed when it just suddenly stopped working.
    I tried to send a test email on other email accounts I own and it did work but here’s the thing, there’s something wrong with it.

    You cannot send a test email to the same account twice, without first changing the email and sending that out and then you can send out the email again to the same email account. The second time it sends it out nothing happens. Formidable and WooCommerce are both setup correctly. As I said, nothing was changed. Even Settings / General Email Address is set to the Gmail account.

    Currently, right now, it still won’t work with anything but the test email on WP Mail SMTP. But noticed a strange issue with that now.
    Sending to any AOL Email: It will send an email out. My phone shows the notification of WP Mail SMTP HTML Test email, but when I go into the email it’s not there. It’s not even in the inbox or spam folder.
    Sending to any Hotmail Email: Shows up in the inbox perfectly fine.
    Sending to any Gmail Email: Does nothing.
    I don’t have Yahoo to test it on.

    Enabling all my plugins back nothing changed. Same strange issue with AOL, & Gmail still exists.
    Since WooCommerce sends New Order forms to the Gmail account using WP Mail SMTP, the plugin just won’t send them out because it does nothing.

    I hope I made this a bit more clear.

    I wonder is the issue that gmail or AOL are blocking the email as spam before it even hits the inbox?

    Is the website domain and email domain the same address?

    When you said “WP Mail SMTP v1.4.2 just gave up on sending emails.” Did it show up an error or did it just not reach your inbox?

    Do use use the gmail smtp or other smtp?

    By “same address” both domain and email have the same name.
    No WP Mail SMTP v1.4.2 didn’t show up any error when sending anything out.
    I use Gmail SMTP Mailer

    Just going to the email and skipping the plugin, on Gmail I sent out an email to any of my AOL accounts and it does the same thing. Shows up on the phone as a notification and nothing in the inbox.
    I even tried sending an email from the same Gmail account to itself and it shows up for a split second in the inbox and disappears.

    For the heck of it, I tried doing the exact same thing on another Gmail account and it worked fine. The Email was in it’s own inbox. I think Google is filtering & or blocking that email that WP Mail SMTP is attached too.
    Do you have any idea how I can get that fixed?

    I know you get those spoiled little brats at times that create fake accounts on WooCommerce and bogus emails that don’t exist then end up with Delivery Status Notification (Failure) and that keeps trying to reach out and deliver it.
    So I guess I can’t send out an email to myself on that Gmail account which is why WooCommerce & Formidable are not working.

    I’m not sure how I can get Google to unblock the email. I really don’t want to make a new Gmail account and attach it to WP Mail SMTP just for it to happen again.

    Well, just found out that all the AOL accounts and the main Gmail account that WP Mail SMTP is attached too are forwarding all the emails to the trash.

    I’m not sure how to fix this one. Since both Gmail and AOL are doing the same thing.

    Ok. Good news. Found out what the issue was. It was my fat thumbs lol.
    Let me explain.

    I ended up removing all Third-party-plugins from Gmail.
    I then sent myself an email to the same email I sent it out by. It stayed in the inbox and didn’t end up in the trash.
    I then sent an email to one of my AOL accounts and it also stayed in my inbox.

    I then enabled my App called: Edison Mail. Edison Mail lets you connect all types of emails to the app and you can check/send everything there. Actually its a really great app. I then checked the trash on the app and seen all the emails there. I clicked on the Email that was used WP Mail SMTP “Gmail” and seen it was blocked. Well, that made a lot of sense. If the app is forwarding the emails to the trash it will do it across all emails connected to the app I tried it on since all of them are controlled by the app. Well I unblocked it and I retried sending an email from Gmail to AOL and it worked.

    Since I wiped all Third-party-plugins from Gmail I had to set up WP Mail SMTP with Gmail again.
    I did an Email test with WP Mail SMTP, Formidable, and WooCommerce and it all worked perfectly fine.

    I guess other users purchasing didn’t have an issue. It was just Edison Mail App forwarding all emails to the trash labeled the Gmail account I used with WP Mail SMTP.
    I must’ve pressed on block by accident and never realized it lol.

    Well, the mystery is solved. Yay. It wasn’t WP Mail SMTP. It worked just fine I guess lol.

    • This reply was modified 6 months, 1 week ago by hobgoblins.
    Plugin Support Jess Quig

    (@jquigam)

    Hi hobgoblins,

    Phew, I’m glad you were able to get to the bottom of that odd issue! And thanks for taking the time to let us know (even unusual issue details can potentially help us to better help others down the road).

    Have a good one 🙂

    Very True Jess 🙂

    I’ll know next time to check Edison Mail App first.
    Could’ve been a one button press fix lol.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WP Mail SMTP Not sending any Emails’ is closed to new replies.