Support » Plugin: WP Mail SMTP by WPForms » WP Mail SMTP Not sending any Emails

  • Resolved marianodevbus

    (@marianodevbus)


    I have the free version of the plugin with wpforms and I don’t receive the forms in my mail.
    I’m using the Office 365 SMTP Settings.
    I get an error sending the test email

    Thank you very much.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @marianodevbus,

    When you get a chance, could you please try sending a test email (under Settings > WPForms > Email Test) and share the details of the error from that here?

    This will help us to get a better idea of what might be going on.

    Thanks!

    Hi, @sanzeeb3 ,

    Thank you for your answer. These are the details of the error.

    “Could not connect to the SMTP host.

    This means that your web server could not have a connection with outlook.office365.com.

    Typically, this error is returned for one of the following reasons:

    -The SMTP settings are incorrect (incorrect port, security settings, incorrect host).
    -Your web server is blocking the connection.
    -Your SMTP host is rejecting the connection.”

    But if I send direct email, from an email account, I receive the emails but from the contact form I don’t receive them.

    Thanks.
    Mariano

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @marianodevbus,

    Thank you for the details. It seems you haven’t configured the settings correctly, possibly incorrect SMTP Host ‘outlook.office365.com’. In case it helps, here are SMTP settings for popular providers. After you setup SMTP correctly and still having issues, please share the full error log. In case it helps, here’s a screenshot to get full error log.

    I hope this helps 🙂 !

    Hi @sanzeeb3,

    I have followed the configuration help instructions for SMTP settings for popular providers and it still doesn’t work.

    Click here to view the complete error log for debugging

    Versions:
    WordPress: 5.2.2
    WordPress MS: No
    PHP: 7.2.19
    WP Mail SMTP: 1.5.2

    Params:
    Mailer: smtp
    Constants: Yes
    ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Host: outlook.office365.com
    Port: 587
    SMTPSecure: tls
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: OpenSSL 1.0.2k 26 Jan 2017
    SMTP Debug:
    2019-07-26 09:49:43 Connection: opening to outlook.office365.com:587, timeout=300, options=array (
    )
    2019-07-26 09:49:46 Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): unable to connect to outlook.office365.com:587 (Network is unreachable)
    2019-07-26 09:49:46 SMTP ERROR: Failed to connect to server: Network is unreachable (101)
    2019-07-26 09:49:46 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting.

    Thank you very much.
    Mariano

    In this website

    https://wpforms.com/docs/how-to-set-up-smtp-using-the-wp-mail-smtp-plugin/#provider-settings

    it says that you should use

    smtp.office365.com

    but in your error log it says you are using ‘outlook.office365.com’. Do you have the right SMTP host in your settings?

    Have you tried installing an desktop email client (such as Mozilla Thunderbird) and sending emails through that client using those exact same settings? It might help you with debugging this problem. This might help you:

    https://docs.microsoft.com/en-us/exchange/mail-flow-best-practices/how-to-set-up-a-multifunction-device-or-application-to-send-email-using-office-3

    It would help if you would send picture of your settings (where password and username are blurred).

    • This reply was modified 1 month, 3 weeks ago by  kysymysteke.
    • This reply was modified 1 month, 3 weeks ago by  kysymysteke.
    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @marianodevbus,

    Please double check your SMTP settings. Like @kysymysteke said, you’re using an incorrect SMTP host. Please follow this tutorial to get correct SMTP settings.

    I hope this helps!

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @marianodevbus – We haven’t heard from you in about a week, so I’m going to go ahead and mark this ticket resolved. If you still have questions, though, please feel welcome to continue the conversation.

    bwjohnson1

    (@bwjohnson1)

    I have the free version of the WP Mail SMTP plugin (1.5.2) and have noticed that emails have been failing to send (even though the SMTP settings are correct).

    Error Log from Test Email:

    Versions:
    WordPress: 5.2.2
    WordPress MS: No
    PHP: 7.2.19-0ubuntu0.18.04.1
    WP Mail SMTP: 1.5.2

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP Error: Could not connect to SMTP host.
    Host: smtp.office365.com
    Port: 587
    SMTPSecure: tls
    SMTPAutoTLS: bool(true)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: OpenSSL 1.1.0g 2 Nov 2017
    Apache.mod_security: No
    SMTP Debug:

    2019-08-13 20:34:32 Connection: opening to smtp.office365.com:587, timeout=300, options=array (
    )
    2019-08-13 20:34:32 Connection: opened
    2019-08-13 20:34:32 SERVER -> CLIENT: 220 MN2PR17CA0032.outlook.office365.com Microsoft ESMTP MAIL Service ready at Tue, 13 Aug 2019 20:34:31 +0000
    2019-08-13 20:34:32 CLIENT -> SERVER: EHLO $domain
    2019-08-13 20:34:37 SERVER -> CLIENT: 501 5.5.4 Invalid domain name [MN2PR17CA0032.namprd17.prod.outlook.com]
    2019-08-13 20:34:37 SMTP ERROR: EHLO command failed: 501 5.5.4 Invalid domain name [MN2PR17CA0032.namprd17.prod.outlook.com]
    2019-08-13 20:34:37 CLIENT -> SERVER: HELO $domain
    2019-08-13 20:34:42 SERVER -> CLIENT: 501 5.5.4 Invalid domain name [MN2PR17CA0032.namprd17.prod.outlook.com]
    2019-08-13 20:34:42 SMTP ERROR: HELO command failed: 501 5.5.4 Invalid domain name [MN2PR17CA0032.namprd17.prod.outlook.com]
    2019-08-13 20:34:42 CLIENT -> SERVER: STARTTLS
    2019-08-13 20:34:47 SERVER -> CLIENT: 503 5.5.2 Send hello first [MN2PR17CA0032.namprd17.prod.outlook.com]
    2019-08-13 20:34:47 SMTP ERROR: STARTTLS command failed: 503 5.5.2 Send hello first [MN2PR17CA0032.namprd17.prod.outlook.com]
    2019-08-13 20:34:47 SMTP Error: Could not connect to SMTP host.
    2019-08-13 20:34:47 CLIENT -> SERVER: QUIT
    2019-08-13 20:34:47 SERVER -> CLIENT: 221 2.0.0 Service closing transmission channel
    2019-08-13 20:34:47 Connection: closed
    2019-08-13 20:34:47 SMTP Error: Could not connect to SMTP host.

    Seems like there may be an issue with the client passing in “$domain”, rather than the domain of my webpage.

    Let me know if there is any immediate solution.

    Thanks!

    • This reply was modified 1 month ago by  bwjohnson1.
    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @bwjohnson1,

    The error you’re getting usually occurs if you authenticate the improper user (the user/password is incorrect). Make sure you’ve authenticated your Office 365 account and not outlook or other Microsoft accounts.

    Thanks!

    bwjohnson1

    (@bwjohnson1)

    Hi @sanzeeb3 ,

    The username and password of the Office 365 account I’m authenticating with are both correct.

    Notice that the EHLO command with “$domain” fails and gives the response “501 5.5.4 Invalid domain name [MN2PR17CA0032.namprd17.prod.outlook.com]” (I’ve seen this same error with other SMTP WordPress plugins as well).

    Thanks for your help.

    bwjohnson1

    (@bwjohnson1)

    UPDATE @sanzeeb3 :

    The issue was that inside my active Apache virtual hosts configuration file (000-default.conf), I was using ‘$domain’, as opposed to the domain itself, for the ServerName under 80 and 443.

    Once I replaced this in both locations the test email was sent successfully.

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @bwjohnson1,

    Great to know that you sorted it out. And thanks for taking the time to let us know with the details. I really appreciate it.

    Have a good one! 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.