Support » Plugin: WP Mail SMTP by WPForms » WP Mail SMTP – Emails getting rejected

  • Resolved silicapacks


    Hi Team,

    It looks like I have a similar issue to (

    I set up the plugin twice as I wanted to test how the emails would look. However, after setting up GSuite and going through the integration steps like before, my test emails would send, but end up bouncing back. At this point, I’ve tried so many times that my GSuite domain email has been blocked and won’t be able to send emails for another 8 hours (hopefully). If Google doesn’t allow my emails to send once the suspension is lifted, a workaround is to setup another GSuite and remove the old one. However, if the new email is blocked as well, my domain will be blocked from using the GSuite platform. So I need to make sure that before I send another test email, the email won’t be blocked. Below are some details of how I troubleshooted up to this point.

    1) I tested with Everything sent out perfectly.
    2) I set up on GSuite, went through the API steps again and applied it to the plugin.
    3) Test email sent. Successfully sent, but the email was blocked.The response was: “Message rejected. See for more information.”
    4) I checked on the plugin and the “FROM EMAIL” was set to my old gmail.
    5) I uninstalled and reinstalled, then went through the API steps again.
    6) “FROM EMAIL” didn’t change. So I went to settings and saw a button that said click to remove all plugin data when removing plugin.
    7) I checked the above to remove all data, deleted and reinstalled the plugin once more. Then went through the API steps again. This time the FROM EMAIL was set correctly.
    8) Test email sent… email rejected again
    9) I set up a new project in the Google console and went through the API steps once more.
    10) Test email sent… email was blocked for too many bounced emails.

    So as you can see, it’s possible that my last email from step 10 could have went through. However, I only have 1 chance left to send a test email before my Domain is rejected by GSuite, I’ve called Google and even went through chat support, but they won’t be able to help. I’m hoping you guys would be able to.

    FYI, for those of you who can’t change the “From Email” even after reinstalling the plugin, you can go into settings and there should be an option on the last tab to remove all data when uninstalling.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Sanjeev Aryal


    Hi @silicapacks,

    It seems the emails are rejected for some reasons as described in the documentation. Make sure you’re sending test emails to the correct recipient, you may try sending emails to recipients with other mailboxes. Or your site is sending emails in bulk already without your awareness and Google blocked your email address.

    Gmail API does not allow to override the ‘From Email’, that is why the option is disabled and greyed out. The emails are always sent from the Google account you’ve authenticated.

    I hope this helps!

    Plugin Support Sanjeev Aryal


    Hi @silicapacks – We haven’t heard from you in about a week, so I’m going to go ahead and mark this ticket resolved. If you still have questions, though, please feel welcome to continue the conversation.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.